Can't acces AUR. No route to host

I’ve been trying to install packages from AUR for a few days but every helper is giving me some variation of Can't connect to (No route to host).

I’ve tried with yay and paru.

  • yay error:
 -> Error during AUR search: 1 error occurred:
        * request failed: Get "": dial tcp [2a01:4f9:c010:50::1]:443: connect: no route to host
  • paru error:
error: aur search failed: error sending request for url ( error trying to connect: tcp connect error: No route to host (os error 113): error trying to conn

I’ve also tried removed paru and git clone it but I got this error:

fatal: unable to access '': Failed to connect to port 443 after 1154 ms: Couldn't connect to server

and the same thing with yay:

fatal: unable to access '': Failed to connect to port 443 after 151 ms: Couldn't connect to server

I can open the first 2 urls with a browser and a json is returned. If you cannot - then is a problem with your internet or dns. If you can acces with a browser, then the problem is in your helpers. The git urls has to be access with git normally, otherwise they will give 404.

I can see the Json:

so it’s not the dns.

Now the git clones keep giving me the same error

No issue here. It’s likely only temporary; try again later.

Sounds like DNS. Shutdown for a few minutes, check your router (or whatever you connect with), and try again later (an hour or so).

I tried with a different ISP now, and this time I got from yay:

 -> Error during AUR search: 1 error occurred:
        * request failed: Get "": dial tcp [2a01:4f9:c010:50::1]:443: connect: network is unreachable

but the git clone still the same:

Cloning into 'paru'... fatal: unable to access '': Failed to connect to port 443 after 1 ms: Couldn't connect to server

It’s three backticks `: ``` :wink:

1 Like

Just FYI, you need to enclose text in 3 backticks ` or 3 tildes ~ to make it preformatted.

Oops, @yochanan was faster. :stuck_out_tongue:

1 Like

No, not necessarily, web browsers nowadays have their own DNS servers set (Firefox uses Cloudflare for example, check the web browser settings).

Your system may use DNS server X but the web browser may use DNS server Z.

Check from terminal if you can ping as this will use the system DNS server, which should be the same as the AUR helper.

But yeah sounds like a network issue on your end.

Another thing you can test is to use a VPN server to use other network routes, if the issue is located in the ISP network, it often solves this kind of temporary issue (Proton VPN is free for the test).

How do I install ProtonVPN without the AUR?

You could manually download the git content of the AUR from the web and do a manual install.
But you don’t need the AUR to test a ping from terminal.

Do you have a global network issue? If this i the case we can’t do anything. If it is only a DNS problem, then fix your DNS server to Cloudflare or OpenDNS, or Google for example.

Yeah, sorry I forgot.

When I ping I’m getting Destination unreachable: Address unreachable .

I’ve tried changing my DNS with the NetworkManager but nothing changes either.

This maybe useful (generally):


Maybe you didn’t do it properly, your previous reply could have included what you have done because most of the time when someone says “I tried but it didn’t work”, then when we ask him to detail what he has done, he didn’t do what needed to be done… So maybe explain what you have done now.

If the issue is on your ISP side, as said, a VPN may help (but as you successfully access the AUR from web browser, I would think it could be a simple system DNS issue, and your browser uses its own DNS server). Maybe you are banned from the AUR too, this happens for IP addresses abusing the service.

I manage to connect with the VPN finally and it worked, I can ping the aur normally, it’s just a bit slow when I make a search with yay.

How exactly can I know if I had been banned, and if I had what can I do to access aur again?

Everyone else can access the AUR just fine. It’s something on your end unrelated to the AUR.

It will tell you in the error message if the rate limit was reached. That will only happen if you send hundreds of requests per minute. Sometimes this will happen using a VPN with multiple users with the same IP.

OK, and still no information on how you tried to change your DNS servers?
You could access the AUR with web browser so my theory might be valid.

To define your own DNS server in NetworkManager, you need to change the IPv4 settings,
the Method from
Automatic (DHCP)
Automatic (DHCP), Addresses only
and then put in your DNS server(s) below.

Similar for IPv6 - or set it to ignore

And don’t forget to reboot for a fail safe way to apply the new setting. But it would have been good to know how he did it.

oh yeah, forgot about that too.

I’ve used this command: sudo nmcli con mod <MY_NETORK> ipv4.dns <NEW_DNS>

tried with ipv6 too: sudo nmcli con mod <MY_NETORK> ipv6.dns <NEW_DNS>

than I reestarted the NetworkManager Daemon (sudo systemctl restart NetworkManager)

I’ve tried both google Dns and

Well I tried two other different networks, besides the one I use daily.

And one of them I don’t remember ever using AUR with it. If I was banned this should have worked right?