Cannot progress with system updates - "plasma5-themes-breath" dependancy

I’m currently using a Minisforum UM700 Manjaro Edition as my daily driver. I just updated to the 6.9.0-1 kernel, and I have 767 updates to install; however, the GUI updater keeps failing, and when I try updating via terminal, this is what I get:

sudo pacman -Syu
[sudo] password for zacharyb:
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
:: Replace baloo5 with extra/baloo? [Y/n] y
:: Replace breeze with extra/breeze5? [Y/n] n
:: Replace ksysguard with extra/plasma-systemmonitor? [Y/n] y
:: Replace kuserfeedback5 with extra/kuserfeedback? [Y/n] y
:: Replace oxygen with extra/oxygen5? [Y/n] n
:: Replace plasma-integration with extra/plasma5-integration? [Y/n] y
:: Replace plasma5-themes-breath with extra/plasma6-themes-breath? [Y/n] y
:: Replace plasma5-themes-breath-migration with extra/plasma6-themes-breath-migration? [Y/n] y
warning: python-inputs: local (0.5.0-1) is newer than extra (0.5-6)
resolving dependencies…
:: There are 2 providers available for qt6-multimedia-backend:
:: Repository extra

  1. qt6-multimedia-ffmpeg 2) qt6-multimedia-gstreamer

Enter a number (default=1): 1
looking for conflicting packages…
warning: removing ‘jre11-openjdk’ from target list because it conflicts with ‘jdk11-openjdk’
warning: removing ‘jre11-openjdk-headless’ from target list because it conflicts with ‘jdk11-openjdk’
:: jdk11-openjdk and jre11-openjdk are in conflict. Remove jre11-openjdk? [y/N] y
:: jdk11-openjdk and jre11-openjdk-headless are in conflict. Remove jre11-openjdk-headless? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing plasma5-themes-breath breaks dependency ‘plasma5-themes-breath’ required by plasma-theme-minisforum

(That error at the end is the same one that the GUI updater gives me, too.)

Does anyone know what I’m doing wrong?

Please read the update announcements since the last time you updated (October 23 or even earlier). Those are all known problems.

Except the theme thing, this one you may have to remove to update.

This may not be entirely straightforward:
plasma5-themes-breath is required by plasma-theme-minisforum, which is required by minisforum-kde-settings, which conflicts with manjaro-kde-settings.

Maybe someone associated with the Minisforum project can provide Zakanuva with some guidance. Will minisforum-kde-settings be updated for Plasma 6, and if not, can minisforum-kde-settings be safely replaced by manjaro-kde-settings?

1 Like

I didn’t have minisforum-kde-settings installed at all, and when I tried installing it just now, it failed because of that conflict with manjaro-kde-settings just like you mentioned.

I’ve successfully uninstalled manjaro-kde-settings, but when I tried to install minisforum-kde-settings to replace it, I just got the same error about plasma5-themes-breath again…

Why would you do this?

This is the source of your problem.

Remove plasma-theme-minisforum.


Same machine, same problem. sudo pacman -Rc plasma-theme-minisforum set me straight. Proceded with the full upgrade, no problems. Thank you! And has someone told Minisforum about this?

Be careful with that c (cascade) flag.
I would not generally recommend it.

I have noted that a number of those ‘partnership’ packages are specifically being left behind.

I posted some messages and pings on the thread for that:

1 Like

Did that; had to reboot a couple times and lost the old wallpaper and some other details, but almost all the updates/upgrades work now. Now my problem is that electron22 won’t update…

The last lines that the GUI updater’s backend gives me is:

RuntimeError: gsutil failed to download "gs://chromium-optimization-profiles/pgo_profiles/chrome-linux-5359-1669828006-dacdfc44d4f579ebe8c296dd8005586434849f0e.profdata"
==> ERROR: A failure occurred in prepare().

…So now what do I do?

Is an unsupported AUR package.
Why do you have it?
Do you need it?

1 Like

Trying to remove it gives me this:

Checking dependencies...
Failed to prepare transaction:
could not satisfy dependencies:
- removing electron22 breaks dependency 'electron22' required by revolt-desktop-git

Do other versions of Revolt not use electron22, or is that app just not usable on Manjaro anymore?

I dont know. But this one does require electron22.

But it takes something like 40 gigs of memory to build.

So … if you do need it you might instead try for electron22-bin

1 Like

Alternatively, look for other sources of revolt-desktop. You can download the AppImage version from their GitHub or install revolt-desktop-appimage from the AUR. Neither of these require electron22, so we can avoid that whole mess entirely.


Uninstalled them both, installed electron22-bin, and reinstalled revolt-desktop-git; it required a reboot to finish the job, but everything’s updated now and there don’t appear to be any remaining issues.

Thank you for the assistance!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.