Cannot mount my USB hard drive

Hello everyone,
my newly installed Manjaro XFCE cannot mount my USB hard drive. What can I do?

Hello @Tut_tut :wink:

Go to Windows and check the disk with chkdsk. The new ntfs3 kernel driver is very picky about problems and will refuse to mount a ntfs file system when in dirty state and there is no tool to check the ntfs filesystem on linux, beside ntfsfix. Usually the reason is that Windows leaves the filesystem in a dirty state.

If you want to use the older userspace driver ntfs-3g, then blacklist ntfs3.

echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf

Just for the sake of knowing:

ntfs-3g has default option which is called recover and this removes the dirty bit instantly.

ntfs3 doesn’t have a recover option, but only: force. That means it will ignore the dirty bit, but disabled by default.

Note that both approaches can be dangerous, since this dirty bit is meant for checking the FS on the next mounting process, so usually on Windows. Linux does not and is not able to check the consistency of your data when using ntfs.

Also, please stop posting pictures.

Try mounting the device in CLI and provide that output, rather.

And just in case you forgot:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Lack of useful install data aside, you can always try running udiskie (on x11) to see if that helps.

I have put the driver on the blacklist. Mounting still didn’t work. How can I undo this? Sorry, but I don’t have enough knowledge.

Is the ntfs-3g driver installed?

pamac install ntfs-3g


To undo the blacklisting, simply remove the newly created file:

sudo rm /etc/modprobe.d/disable-ntfs3.conf

Many thanks for the help!
I’ll take care of the problem later, but I can’t do it now.

P.S: Unfortunately, I also couldn’t mount the USB drive in a live system with Linuxmint. I therefore had to use another backup. I deleted the USB drive and reformatted it with a full EXT partition.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.