Cannot export from mysql community

Ok, before I begin I will tell you this is a tool required by an assignment that is overdue but my prof is still expecting. Also, so that you know, not only can my prof not help, but neither can anyone else at the school, we have all tried. And I mean tried! My prof did not leave me in the dust to figure this out on my own, he has tried, tech support has tried, and so has my course advisor (who had no clue what to do even tried) to no avail. This is a software issue regarding my Manjaro KDE version vs. MySQL Workbench not allowing me to complete my assignments. My prof, and my course advisor has given me permission to look for outside sources for help.

Now that intro has been made, here is the problem: I need to Export All however, when opening the file, almost all tools are faded. I noticed at the top where the tab for the file is says unconnnected. So, I figure I had to make a server in the software in order to have use of the tools. I have the tool MySQL Workbench installed on my computer. I have created a user with their own password. I have also stayed with root and tried to create a blank password to no avail. However, when creating a server in order to use the tools in the software, it will not allow me to use the password and I will receive an error message:

Could not store password: user interaction failed

I have tried tinkering with the SSL tab using the SSL Wizard, but also get error messages. I have uninstalled and re-installed the software at least 100x starting fresh with the same information on how to install and set up a user on the software and even sometimes leaving the user part out and staying with root. It does not matter which way I go, I get the same results. And yes, before you ask, I did make sure the liabio library was also installed. I have also tried using some of the snap commands to try to bypass the password issue that seems to be the trouble. Including:

snap connect Mysql-workbench-community:password-manager-service

snap connect mysql-workbench-community:ssh-keys

If I seem a bit irate, it is probably because I went over everything over and over again for months now with no result. It could also be because this is the 3rd time taking this class with the same issue. This is costing me time and money I cannot afford. This is not a specific requirement of the course itself, it is just a tool needed. Also, they have suggested many times that I revert or replace my computer with a Windows OS! They pointed out that should I have used a Windows OS instead, we would not be having any problems. I have only one more course after this before graduation, I would greatly appreciate it if someone could help me!

Damn, whole university can’t google. :joy:

Install gnome-keyring and don’t use snap.

already tried gnome keyring…

pamac install gnome-keyring  :heavy_check_mark:  6s 
Warning: gnome-keyring-1:42.1-2 is up to date – skipping
Nothing to do.
Transaction successfully finished.

also the snap thing was a recent attempt after everything else failed

Forum rules

As a matter of principle, do not ask for homework answers, nor post answers to such requests. Homework assignments are designed to encourage a student to learn by their own personal research. Topics deemed to be about homework will be closed.
Forum Rules - Manjaro

The following will therefore not be the answer you are looking for but merely pointing you to further reading.

Windows vs Linux

MySql and by inheritance MariaDB was created for Linux - likely on Linux as well. Telling you to use Windows, and you would have no problems for the task at hand - is ignorance at best - stupidity at worst.

You may quote me.

MySQL vs. MariaDB

MySql Workbench is a tool which does nothing on it’s own. You must first define a connection - then you need to connect to the server using the connection you defined and will connect to MariaDB instances as well.

MySql is not in Manjaro or Arch repo - and thus unsupported - instead MariaDB is offered.

MariaDB is a reliable, high performance and full-featured database server which aims to be an ‘always Free, backward compatible, drop-in’ replacement of MySQL. Since 2013 MariaDB is Arch Linux’s default implementation of MySQL.[1]
MariaDB - ArchWiki

For installing, and setting up a MariaDB instance - consult the following topic

MariaDB maintains a comprehensive knowledgebase - it is highly recommended resource on MySQL transaction language.

After manually installing the components to mysql through Konsole I got the message Welcome to Mariadb … I am sure my system has that but the PHP not so sure so I will follow the directions and see if that solves the problem. I will let you know if it does or does not work. Everything so far has not so I will not hold my breath.

Ok, everything was going well until systemctl status httpd. It said I should see this:

systemctl status httpd

● httpd.service - Apache Web Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; preset: disabled)
Active: active (running) since Fri 2022-11-11 13:03:33 CET; 4s ago
Nov 11 13:03:33 test systemd[1]: Started Apache Web Server.

however I received this:

[CCollyer ~]# systemctl status httpd
○ httpd.service - Apache Web Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; preset: disabled)
Active: inactive (dead)

It does not give what to do if service and Active are disabled and inactive.

Also, just received this from my prof:

ignore that I was able to fix the service and active status. However, this appeared at the bottom:

May 23 13:32:35 CCollyer systemd[1]: Started Apache Web Server.
May 23 13:32:35 CCollyer httpd[68586]: AH00558: httpd: Could not reliably determine the server’s fully>
set mark:

new problem that might also show the reason why nothing is working. When I entered:

micro /srv/http/index.html

and then

<h2>It works!</h2>

and went to the sudo server


I received an error.

Hmm. We’re having trouble finding that site.

We can’t connect to the server at ip.x.y.z.

If you entered the right address, you can:

The search tab says 'Server Not Found'

and the screen on the page says:

Hmm We're having trouble finding that site.
    Try again later
    Check your network connection
    Check that Firefox has permission to access the web (you might be connected but behind a firewall)

So I went back to Konsole and saved to try again and received a message at the bottom:

Permission denied. Do you want to save this file using sudo? (y,n)

After I said y nothing changed. After that I closed Konsole and re-opened and entered root su -l root again and tried again. Same results except for the permission denied message after saving. The server website I still received the message.

Yes, I like to try to follow through with things to see what I can do on my own.

nothing is clear in your request!
workbench is only a client, where is your server ? (local, school, …) you want what with workbench ?

snap connect mysql-workbench-community:ssh-keys

I suppose only a connection at scool ? so, not install local serveur
you use an SSH Tunnel for connection to scool ? it’s not an sql server error ?

Why do you want to install a web server now? This was not your initial request.

There are also many other clients, maybe you should also test a connection with…
mariadb-clients, DBeaver(gui),…

papajoke, I was pretty clear about what is going on. I cannot use the workbench tools and when opening the file I need to work on, the tab at the top says unconnected. It seemed like a message telling me that I needed to establish a server within the tool in order to use the tools such as Execute All. I cannot do my work if I cannot access the tools. Also, this is a remote school so I am working from home.

This was in my initial post:

Actually you were not. I think you don’t understand that MySQL workbench is only a client tool to connect to a database server (MariaDB seems to be in this case). The database server can be in your own computer or can be in other computer and Workbench can connect to it through the network. That’s why Papajoke was asking where is your server. If I got right, your server is a local MariaDB installation, so you don’t need SSH, SSL, HTTP server, PHP or any other third party program. If you only want to use the database you don’t even need MySQL Workbench. You could use another client, for example the command line mariadb client.

Another thing that is not clear to me is what do you actually need to export. If I understand you correctly, your Workbench is not able to connect to the server, so it shouldn’t be anything to export.

I think that the best approach is to cut the middleman and try to get a working server using the command line client (mariadb). And when you have that working, you should connect without problems from Workbench.

Anyway, how did you create the database user you are trying to use in the first place?

You have filled so much information in several more than 100 words paragraphs - including several paragraphs on your attempts to create a server with a client application.

This has all lead us to think the issue is the missing server connection where it is only a matter of modelling a database which is done completely offline.

In fact your OP is 502 words and 2,669 charaters …

No matter the operating system - you would have had the same issue - your issue is not the operating system …

Then why are you faffing with the connection properties?

You can easily work with database models without a connection!

You should really pay more attention to what is said in class - instead of - whatever you are doing - for the third time …

I see - you have confused yourself - you don’t need a db connection to be able to work with db modelling.

I think we are having the XY problem - Wikipedia

The XY problem is a communication problem encountered in help desk, technical support, software engineering, or customer service situations where the question is about an end user’s attempted solution (Y) rather than the root problem itself (X).[1]

The XY problem obscures the real issues and may even introduce secondary problems that lead to miscommunication, resource mismanagement, and sub-par solutions. The solution for the support personnel is to ask probing questions as to why the information is needed in order to identify the root problem X and redirect the end user away from an unproductive path of inquiry.[2][3]

Why all that chatter on the connection if all you need is to work with a db model?

Did your professor instruct you to use MySQL Workbench to connect to his server instance?

Did your professor instruct you to setup a local server - on your computer?