Cannot connect to eduroam

Hello. I cannot connect to my university’s eduroam connection on Linux. Eduroam connects just fine on Windows. Weirdly enough, eduroam cannot connect on any linux distro that I use, I’ve tried to connect to eduroam on freshly mounted boot-drives of KDE Manjaro, KDE Ubuntu, Gnome Ubuntu and all have failed. Only Windows works.

My computer can connect to other wifis other than eduroam.

What is common amongst all these distros is that when eduroam fails to connect, I get the following type of error on dmesg.

[ 46.540584] wlan0: disconnect from AP ac:4a:56:c2:50:cf for new auth to ac:4a:56:c3:33:4f
[ 46.816481] wlan0: authenticate with ac:4a:56:c3:33:4f
[ 47.007159] wlan0: send auth to ac:4a:56:c3:33:4f (try 1/3)
[ 47.010510] wlan0: authenticated
[ 47.013858] wlan0: associate with ac:4a:56:c3:33:4f (try 1/3)
[ 47.023942] wlan0: RX ReassocResp from ac:4a:56:c3:33:4f (capab=0x1111 status=0 aid=1)
[ 47.054359] wlan0: associated
[ 47.083489] wlan0: Limiting TX power to 17 (17 - 0) dBm as advertised by ac:4a:56:c3:33:4f
[ 55.180686] wlan0: deauthenticating from ac:4a:56:c3:33:4f by local choice (Reason: 3=DEAUTH_LEAVING)
[ 62.259952] wlan0: authenticate with ac:4a:56:c3:33:4f
[ 62.293446] wlan0: send auth to ac:4a:56:c3:33:4f (try 1/3)
[ 62.305359] wlan0: authenticated
[ 62.306280] wlan0: associate with ac:4a:56:c3:33:4f (try 1/3)
[ 62.312346] wlan0: RX AssocResp from ac:4a:56:c3:33:4f (capab=0x1111 status=0 aid=1)
[ 62.342745] wlan0: associated
[ 62.342778] wlan0: Limiting TX power to 17 (17 - 0) dBm as advertised by ac:4a:56:c3:33:4f

The deauthenticating with Reason: 3=DEAUTH_LEAVING is common in all distros.

I have tried downloading the certificate file from the eduroam website, and that did not fix the issue. I have also tried various fixes found on the internet, but none have worked.

Funnily enough, eduroam used to work earlier, and my university’s IST had did some update after which eduroam stopped working for me. I spoke to IST and after many back and forth emails they essentially said that they won’t do anything since “my system is not supported” (even thought Ubuntu should be supported by them, and it doesn’t work on Ubuntu either).

Any help is appreciated!

That suggest issue with too aggressive power save on your wifi card. Please provide info about your wifi card (eg. inxi -Na)

Thanks for the quick reply! Here is the output of inxi -Na

Network:
Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel bus-ID: 0000:02:00.0
chip-ID: 14c3:7961 class-ID: 0280
Device-2: Realtek vendor: ASUSTeK driver: r8169 v: kernel port: 3000
bus-ID: 0000:03:00.0 chip-ID: 10ec:8162 class-ID: 0200

I don’t see your device is tricky or have special settings around powersaving so common solution for disabling it for eduroam should be enough (change eduroam to your SSID if you have other):

nmcli connection modify eduroam 802-11-wireless.powersave 2

You can also disable powersaving globally as described here.

I tried using the fix you described, but it did not solve the problem. I tried both the command you specified, and also tried to change add the file in conf.d.

I’m still getting the same error of Reason: 3=DEAUTH_LEAVING.