Cannot boot Live USB (ERROR: failed to mount /dev/loop0)

I’m trying to boot manjaro-xfce-20.2-minimal-201203-linux59.iso on an ASUS K75VJ (2012-2013) with no success. The following shows up after GRUB menu:

ln: /dev/sda: File exists
mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error
ERROR: Failed to mount ‘/dev/loop0’’
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can’t access tty: job control turned off
[rootfs ]#

Laptop specs are:

  • CPU: Intel Core i5-3210M
  • GPU: Intel HD graphics 4000 + NVIDIA GT635M (Optimus)
  • RAM: 8GB DDR2
  • HDD 250GB.

It has UEFI support, but I’m not sure what type (bios is AMI version 234 for this model)

I’ve already tried the following:

  • Rufus on DD mode
  • Ventoy
  • DD iso to the USB from Ubuntu terminal
  • Using different USB disks/sticks
  • Verifying checksums
  • Switching to IDE mode on BIOS
  • Checking USB for damaged sectors

All methods gave the same result.

I could boot it on a more modern PC with z370 chipset and intel 8700K, just to make sure live USB was really working, so it has to do with my laptop.

Any ideas?


Also getting that error on one of my old laptops with ventoy.
Was able to fix it by re-downloading the file and using a different stick and doing a dd to it.

1 Like

How lucky! I did the same, even tried with an external hard drive but didn’t work :frowning:
did you use any special parameters with dd?

You said you verified the checksum after transfering the ISO data to the stick. If the checksums match then you should be fine. If you are not sure, double check your procedures:

When using dd it could be required to reduce the bs= parameter if you have a slow USB stick or only use USB 2.0 port.

Manjaro ISOs are of hybrid design, means they can be used for BIOS(legacy) and alternatively for UEFI boot. You need to select the right entry when booting the stick from your firmware. Usually, the UEFI entry has “UEFI” at the begin of the name.

1 Like
emmanuel@emmanuel-k75vj:~/downloads$ sha1sum manjaro-xfce.iso
114dca0d6033922017e4371d45e7e1022d51e3ce  manjaro-xfce.iso
emmanuel@emmanuel-k75vj:~/downloads$ sudo dd if=manjaro-xfce.iso of=/dev/sdd bs=1M oflag=sync status=progress
[sudo] password for emmanuel: 
2052063232 bytes (2.1 GB, 1.9 GiB) copied, 271 s, 7.6 MB/s 
1958+1 records in
1958+1 records out
2053425152 bytes (2.1 GB, 1.9 GiB) copied, 271.368 s, 7.6 MB/s
emmanuel@emmanuel-k75vj:~/downloads$ sudo dd if=/dev/sdd iflag=count_bytes count=2053425152 | sha1sum
4010596+0 records in
4010596+0 records out
2053425152 bytes (2.1 GB, 1.9 GiB) copied, 6.82946 s, 301 MB/s
114dca0d6033922017e4371d45e7e1022d51e3ce  -

I doubled checked both ISO checksum and the USB with ISO after dd with bs=1M using the method you posted, and both are OK. Still doesn’t boot!

Regarding UEFI/BIOS options, I had both shown up when I tried before posting and none worked…

OK, at least we know now that the data on the stick won’t be the reason for your problems.

Further ideas:

  • Disable secure boot in case it’s enabled in your firmware.
  • Set SATA mode from IDE to AHCI.
  • Check for BIOS updates.
  • Check hardware.
1 Like

Yeah, secure boot disabled, either IDE/AHCI tried and none worked. BIOS updated to its latest version and hardware seems working fine. Would only check for RAM issues but never had any problems with it.

What I would love to know more about is if there’s any hardware related boot parameters I can play with on this OS, never been a great GRUB connaiseur. Worth the try?

For example one I tried was acpi=off and acpi=noirq, but did nothing.

Something similar happened to me, with the difference that the error had the output: ERROR: Failed to mount /dev/loop3, I solved the error using the same problematic USB memory, what was the problem? force the eject of the memory after the graphic window will show that the ISO copy was made successfully (I clarify that I use Ventoy).
This is a detail (it does not deserve to call it a problem since GNOME, cinnamon and KDE handle this very well) that I have been seeing for several years, although the graphical interface shows us that the copy has finished, it is still working in the background for at least 10 minutes.

SOLUTION: recreate the bootable USB, in the case of Ventoy copy the ISO and wait at least 10 minutes after the graphical interface tells us that the job is finished.
A clear sign that this happens is that the file manager does not allow us to eject the device because it is busy in some process.
the waiting time may vary depending on the power of the computer or the type of USB memory.