Cannot boot after ten times of re-installations

At the eleventh time, I have been able to boot to Manjaro. I would like to share my pains and lessons learnt after ten times of re-installations. Here are some of my suggestions:

1. /boot/efi partition

The instruction when installing was unclear. After I partitioned my disk, I received a warning: make sure that you created a FAT32 partition with mountpoint /boot/efi, and with flag boot enabled. I was sure that all the requirements above were satisfied. However, the warning still appeared.

It turned out that the /boot/efi partition must be at least 512 MB so that the warning is turned off. During my installation, I chose a 260 MB partition (this is the default size after installing Windows).

After a few tries, I realized that all the requirements above are not sufficient. The /boot/efi must be an “EFI System Partition” ( This should had been informed during the installation.

At the end, I ignored the warning, chose the 260 MB partition for /boot/efi.

2. grub

For some reason, update-grub only worked in btrfs file system. When I used ext4 for my root partition, it complained that: this script is only available for btrfs snapshot. Eventually, I gave up with ext4 and chose btrfs for my root partition.

If ext4 is not supported, please show a warning during the installation.

3. efibootmgr

After a few tries, I was able to boot to Manjaro by pressing F9 on startup. If I don’t intercept the startup, Windows will be chosen by default. To set Manjaro as the default OS, I had to use efibootmgr.

I suggest that efibootmgr should be included in the last step of the installation.

Welcome to Manjaro forum

If the script is only for Btrfs snapshots it is probably from grub-btrfs and would not work with Ext4 partitions

Manjaro User Guide included on Live ISO has information about Manual installation on a UEFI system using FAT32 and Ext4 partitions

This tutorial has information about installing with Btrfs

1 Like

If the script is only for Btrfs snapshots it is probably from grub-btrfs and would not work with Ext4 partitions

Yes. That’s the problem.

I am quite sure that if I repeated the same step from the User Guide, I would still face the same error when running update-grub.

I think it is unlikely calamares would install a package related to Btrfs if you followed the User Guide to create Ext4 partition(s)

If the same error did occur and calamares failed to install GRUB, you could maybe try uninstalling grub-btrfs

Hi, the EFI partition type error is a bug present in the 21.0.7 ISO. It’s already been fixed in the newer ISOs.

The size of the ESP depends on what you are going to do with it. Manjaro uses only like 150KiB. Windows uses like 30MiB. Other Linuxes may vary depending on if they put the kernel there or on the root partition. My ESP is 100MiB size and half of it is empty.

And AFAIK default installations don’t use btrfs. So your case it’s a little bit estrange.

One day I will reproduce the issues and post a video here. Hopefully I have time for that.

1 Like

Today, I tried to reinstall Manjaro using the latest version. I am glad that all the issues disappeared.

  1. /boot/efi: I noticed there has added a warning saying that the EFI partition should be at least 300 MB.

  2. grub: When I used ext4, update-grub (for ext4) has been installed correctly.

  3. efibootmgr: I noticed that this issue happens with other distros also.

1 Like