Can’t install Manjaro

Hi! I’m trying to install the latest Manjaro version. I’ve created my boot flash drive via Rufus on Windows 11. But every time I boot from my USB flash drive and click on “Boot with open source drivers”, I get “Starting systemd-udevd version 252.4.2-manjaro” and nothing else. What am I doing wrong?

Did you try proprietary drivers? :thinking:


inxi -F

Where should I run this? I’m installing Linux for the first time on my new PC and I didn’t get this error anytime before.

@Thenujan Yes, it didn’t work either.

Yes, it didn’t work either.

How new?

Did you verify the ISO was complete - checksum or signature - because a damaged download behaves very strange.

The docs suggests using Etcher on Windows

And for the record - your information is way to minimal to act upon.

So, I recreated my flash drive according to the tutorial, that you’ve sent, but I’m still getting black screen with “Starting systemd-udevd version 252.4.2-manjaro”. If it’s necessary, here’s my setup:

  • CPU: Intel Core i9-12900K
  • GPU: Nvidia RTX 3090
  • Memory: 32 GB DDR4

add on boot option

see Changing kernel version causes boot hang during "audit" - Intel 12 & 13 gen - #2 by stephane

Okay, that kind of worked. Now I’m stuck on the loading screen. There are my motherboard’s logo, Manjaro’s logo and three animated dots.

Update: I booted up with proprietary drivers and now everything works fine (as far as I can see). Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.