Can’t install Manjaro i3wm

Hi everyone, I’m new to manjaro (and linux in general) and i would like to install it, but I’m struggling on it.
I recently bougth a laptop in which i wanted to make a dual boot. I installed windows, made a partition for linux, booted manjaro on an USB and opened it. Then i chose my language, my keyboard distribution… etc. after that, a big cascade of lines started to descend, and got stucked either in:

A start job is running for Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling


A start job is running for udev wait for Complete Device Initialization

i’ve tried to install it many times but I always get one of those messages, furthermore, before the stucked message it is always written:

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0
See ‘systemctl status systemd-backlight@backlight:acpi_video0.service’ for details.

I also tried to install Manjaro Gnome, Ubuntu, and ArchLinux. in the last one, i get the same error, while in manjaro Gnome and Ubuntu they freeze during a loading screen.

my laptop is an Acer Aspire 3 A315-23-R9BD

Hi and welcome!

In general (my experience) Acer give a **** on Linux. Their support is rubbish and the UEFI prevent you to install it. Also flashing a new UEFI works only on Windows.

BUT… there are some tricks to let it work. You need to disable some features or let the UEFI thinking that it is using Windows. That is done with grub:

Here you can write parameter that takes effect on the boot.

This way you can disable the TLP service for example:

While in the Grub Menu of Live media, press e to edit it, and append after quiet this line


Then press F10 to save and continue booting.
Is that helping?
If that is a desktop pc, i would recommend to remove tlp

This way you make the UEFI thinking it is using Windows:

Now your post:

That is quite normal, when it doesn’t hangs and just take some time.

That is a known problem, but caused by the UEFI. You need to disable it .You can mask it in the grub boot menu (described above) like this:


Here is also a collection of power setups:

Sorry, that you have this experience, but in that case it is not the fault of Linux. :sob:

Hi again
The problem is solved, and manjaro opens, however, when I open calamares, the entire screen freezes after exactly 32 sec, showing:
waiting for 2 module(s). 32 second(s)