Can overclock Raspbian Lite but not Manjaro

Got an RPi4.
I was able to successfully overclock my RPi4’s CPU to 1850MHz and the GPU to 635MHz on Raspbian Lite with KDE desktop.
But the same config on Manjaro doesn’t boot.
Whats’s the problem ?

The problem, I think, is Raspbian vs. Manjaro.
They’re not the same. Raspbian is a fork of Debian, while Manjaro is a fork of Arch. Completely different distributions. Yet they’re both Linux. The same…but different…

Google search shows that people have overclocked RPi 4 to 2GHz on Manjaro too.
The keyword I used: “manjaro kde pi 4”

I didn’t say it can’t be done. I said the way to do it with Raspbian might (probably won’t?) work on Manjaro. (No, I don’t know, or care to know or do it in either OS.)

After 1 quick search, this was the top result: How to overclock Raspberry Pi4 in Manjaro/ Übetrtakten eines Raspberry Pi4 in Manjaro ARM - #3 by waldmattis

I am not sure if you are looking for tips or an explanation. You do not offer much information concerning your situation. Many are successful with overclocking on Manjaro.

This is my current /boot/config.txt file:

# See /boot/overlays/README for all available options

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4


Which doesn’t boot :expressionless:

Well, I don’t have a Raspberry PI anymore and neither any less, so this is just a shot in the dark.

Are you sure it’s not overheating?

It should help to troubleshoot the problem if you try booting with the settings that doesn’t work, switch it off, change it back to working settings, boot up and check the logs. Or something like that.


Because along with overclocking usually comes overheating.

I’ve gone through it I can’t even overclock only CPU to 1600MHz and I’ve got the aluminum armor heat-sink case with dual fan.
It is less likely to be overheating.

Tried dropping this to 5?

1 Like

Tried 3,4,5

Got a question where are the boot logs ?
So I can give more precise details or even make it more googlable.

# overclocking

I recently removed gpu overclocking due to a change in the 5.12 kernel.

I assume you removed the overclocking and it booted correctly. Just bump up the overclocking in increments until you find what works for your system.

GPU overclock is far more important to me than CPU overclock. Since I use it as a home media player.

Can you provide me a link to the changes you mentioned ?

And do you think that if I use the older kernel, I may use the overclock ?

I just migrated from Raspbian to get rid of really old software releases on debian.

If you are using fkms, then you should be fine with the 5.12 kernel.

Nope fkms didn’t work for me, even with GPU clock set to 630 :expressionless:

Does it boot without overclocking?

Yes. It’s perfect though on with just a bit of lag. But not youtube.

I overclocked my RPi 4 on Plasma Bigscreen too!
Hence there’s not a problem on overclocking the 64 bit architecture.

Update: I can overclock Manjaro Minimal too but not with any DE.