Can only open certain webpages


Recently swapped from win 10 to manjaro but i’m constantly having network issues were i can only open certain webpages (ie the manjaro websites and YouTube) i get these same problems when not using Ethernet instead using wifi and i even have these problems with application (ie steam cant connect to update).

Please Help

Can you provide more information about your system, network, and browser(s)?

To rule out one possibility, are you using any type of VPN connection, whether locally configured in Manjaro or perhaps on your router?

Network wise i’m not running a VPN or a Proxy. I’m running an Ethernet cord into a wifi extender. And there defiantly isn’t a vpn on my router.

What network card is it?

inxi -N

It doesn’t sound like a browser-specific issue, since you said even your Steam client cannot fetch updates? So some web addresses work, but not others?

What happens when you try to ping an address, such as


Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi

Going to steam says the page cant be found and pinging it says its unreachable.

What if you try to ping this IP address:

network unreachable

Can’t even ping their IP address?

To rule out another possibility, have you tried connecting directly to your router, rather than through the extender?

No. Because then i would have to move my pc setup to another room.

I understand. Is this a Netgear PowerLine extender by any chance?

I’m scratching my head here, since you cannot even ping an IP address directly, which likely rules out a DNS-related issue.

Maybe someone with greater familiarity with this particular problem can jump in.

It is netgear but i’m not sure what model i bought it quite a while ago.

The reason I ask is because I experienced a very similar issue to what you are describing when using Netgear PowerLine extenders. (I’ve since sold them on eBay and went with something else.) It could be an entirely unrelated issue with what you’re facing, however.

You are probably experiencing the same issue.

Just checked the extender its a “N300 Wifi Range Extender”.

Another thing you can try to is use the r8169 driver instead of r8168.

But you said your Manjaro system exhibits the same behavior whether you connect with your WiFi (Intel, iwlwifi) or Ethernet (Realtek, r8168)?

Yes but on the off chance my internet decides to work how would it change the driver.

Is your PC within distance of connecting directly to the router via WiFi, bypassing the extender, just for this test?

No its in a room across the hall and i don’t have a big enough Ethernet cable.

I meant using the PC’s built-in WiFi (Intel, iwlwifi) to connect to the router, even if it’s a “weak signal”, it’s just to test something out as a process of elimination.

Manajro Settings Manager > Hardware Configuration > then you should see an option to switch to it. (I’m going from memory here, so I could be wrong. I believe it automates switching over to r8169 by modifying a blacklist entry for a .conf file under /etc/modprobe.d/ )

Small problem the signal is so weak it cant “securely connect” and the connection device stopped working and i had to reenter my password but still no luck.

So would i just remove blacklist r8169 from the r8169_blacklist.conf file?