Can no longer get to KDE GUI after installing 5.13 kernel


I was running on kernel 5.11. I did a full system upgrade (via the kde gui - add/remove software), I then rebooted the system and it came back ok. I then decided to install a newer kernel - 5.13. I didn’t apply the new kernel, I just installed it.

After installing 5.13, I then rebooted the laptop and I got a screen saying press CTRL-D and enter root password.

I dropped into chroot and thought maybe I needed to rebuild manually so I did a mkinticpio -P but I got the following errors:

==> ERROR: module not found: nvidia
==> ERROR: module not found: nvidia_modeset
==> ERROR: module not found: nvidia_uvm
==> ERROR: module not found: nvidia_drm

I’m not sure what I need to do now - on the boot screen I only get the option of selecting kernel 5.4; I’m using systemd

Any help or pointers would be very much appreciated. I’ve included the following outputs:

mhwd-kernel -li

The following kernels are installed in your system:

  • linux511
  • linux513
  • linux54
inxi -Fza
System:    Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 misobasedir=manjaro misolabel=MANJARO_ARCHITECT_2003 quiet systemd.show_status=1 
           Console: tty 1 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: Notebook product: PCX0DX v: N/A serial: N/A Chassis: type: 10 serial: N/A 
           Mobo: Notebook model: PCX0DX serial: N/A UEFI: INSYDE v: 1.07.07 date: 06/17/2020 
Battery:   ID-1: BAT0 charge: 65.9 Wh (100.0%) condition: 65.9/70.7 Wh (93.2%) volts: 13.0 min: 11.4 model: Notebook BAT 
           type: Li-ion serial: <filter> status: Full 
CPU:       Info: 8-Core model: Intel Core i7-10875H socket: U3E1 bits: 64 type: MT MCP arch: Comet Lake family: 6 
           model-id: A5 (165) stepping: 2 microcode: C8 cache: L2: 16 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 73625 
           Speed: 813 MHz min/max: 800/5100 MHz base/boost: 2178/8300 volts: 0.8 V ext-clock: 100 MHz Core speeds (MHz): 
           1: 813 2: 833 3: 840 4: 842 5: 839 6: 840 7: 843 8: 843 9: 800 10: 841 11: 842 12: 842 13: 841 14: 839 15: 869 
           16: 843 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:9bc4 class-ID: 0300 
           Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: CLEVO/KAPOK driver: nouveau v: kernel bus-ID: 01:00.0 
           chip-ID: 10de:1f15 class-ID: 0300 
           Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 1-8:2 chip-ID: 5986:9102 class-ID: 0e02 
           Display: server: 1.20.11 driver: loaded: modesetting alternate: fbdev,intel,vesa tty: 240x67 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:06c8 class-ID: 0403 
           Device-2: NVIDIA TU106 High Definition Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:10f9 class-ID: 0403 
           Sound Server-1: ALSA v: k5.6.15-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.31 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8169 v: kernel 
           port: 3000 bus-ID: 42:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp66s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 3000 bus-ID: 44:00.0 chip-ID: 8086:2723 
           class-ID: 0280 
           IF: wlp68s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: N/A rfk-block: hardware: no software: no 
           address: see --recommends 
Drives:    Local Storage: total: 5.51 TiB used: 1000.86 GiB (17.7%) 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 211070WD temp: 36.9 C 
           SMART: yes health: PASSED on: 71d 10h cycles: 298 read-units: 192,016 [98.3 GB] written-units: 1,867,666 [956 GB] 
           ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 2B2QEXE7 temp: 31.9 C 
           SMART: yes health: PASSED on: 126d 22h cycles: 230 read-units: 311,532 [159 GB] written-units: 2,992,254 [1.53 TB] 
           ID-3: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Ultra size: 57.28 GiB block-size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
           ID-4: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: BUP BK size: 3.64 TiB block-size: physical: 4096 B 
           logical: 512 B serial: <filter> rev: 0304 
           SMART Message: A mandatory SMART command failed. Various possible causes. 
Partition: ID-1: / raw-size: 100 GiB size: 97.93 GiB (97.93%) used: 34.08 GiB (34.8%) fs: ext4 block-size: 4096 B 
           dev: /dev/dm-0 maj-min: 254:0 mapped: vg02-lvol--root 
           ID-2: /boot raw-size: 767 MiB size: 765.5 MiB (99.80%) used: 677.3 MiB (88.5%) fs: vfat block-size: 512 B 
           dev: /dev/nvme1n1p1 maj-min: 259:3 
           ID-3: /home raw-size: 10 GiB size: 9.78 GiB (97.81%) used: 262.9 MiB (2.6%) fs: ext4 block-size: 4096 B 
           dev: /dev/dm-1 maj-min: 254:1 mapped: vg02-lvol--home 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A gpu: nouveau temp: 45.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 288 Uptime: 24m wakeups: 1 Memory: 31.06 GiB used: 982.8 MiB (3.1%) Init: systemd v: 248 tool: systemctl 
           Compilers: gcc: 11.1.0 Packages: 1447 pacman: 1424 lib: 399 flatpak: 23 Shell: systemd (sudo) running-in: tty 1 
           inxi: 3.3.05 
ls /boot/*






I would:

  • Remove 5.6 [EOL], 5.11 [EOL] and 5.13 [Stable]
  • Add 5.10 [LTS]
  • Remove the nVidia drivers and re-install them without rebooting through CLI
  • Reboot and then try both 5.10 and 5.4 LTS…


P.S. If you wouldn’t know how to do any of the above, please shout out.

Thanks for the advice. That worked and got me back to a working state! Thanks a lot. I hit a few issues though so I’ll post here for future readers…

I went into a chroot session:

Remove 511 kernel
pacman -R linux511
=> Unable to remove module nvidia/470.42.01 for kernel 5.11.22-2-Manjaro: Not found
Error connecting: Could not connect: No such file or directory
error: command failed to execute correctly
(5/5) Updating systemd-boot entries

Seemed to work ok despite the error…

Remove 513 kernel
sudo pacman -R linux 513
checking dependencies...
:: removing linux513 breaks dependency 'linux513' required by linux513-nvidia
:: removing linux513 breaks dependency 'linux513' required by linux513-zfs
Remove 5.6

I don’t have 5.6 installed; that’s just the kernel of manjaro-architect that I’m using to chroot

Add 510 kernel
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
error: no targets specified (use -h for help)

I was reading somewhere that it’s not possible to use mhwd-kernel to install kernels from chroot so I tried pacman -S linux510 instead and this worked.

Remove nvidia drivers

I first queried what I had:
pacman -Q nvidia

I then removed using: pacman -R linux513-nvidia

I then re-installed using pacman -S linux510-nvidia

I then rebooted and I can now select 510 or 513 from my systemd boot menu; I can’t use 5.4 though - still getting some issues there that I need to look into…

2 outstanding questions:
1)Out of interest, I see 5.11 listed in my options in my boot menu but I don’t see 511 when I do mhwd-kernel -li. How do I get rid of 5.11 from my boot menu - just edit bootctl?
2)Do I need to install a nvidia driver for 513 kernel? Or is linux510-nvidia sufficient for working with both 513 and 510?

Many thanks,

1 Like

That’s a completely new question already answered here. :stuck_out_tongue_winking_eye:

Try booting 5.13 Stable and if it works you don’t need to do anything and if it doesn’'t, shout out.


Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Happy to have your reply as the solution. Thanks again!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.