Call sound and earpiece issue

Hi,

I have PinePhone with Manjaro Phosh on it. It has the most of the functions operative, but a big issue i think which is not resolved since a few months ago:

When I call someone and finish, in the sound menu turns on the “earpiece” function, and when someone calls later there is no sound. Sometimes, the “earpiece” function turns on automatically, so the sound is really low, imperceptible.

I think that everyone who uses Phosh knows this, but I cant found a theme about that. Any solution?

Thanks a lot.

1 Like

The same or something very similar happens on Plasma Mobile too.

There is definitely something wrong with how audio profile switching works.

Hello,

You can switch back to pulseaudio instead of pipewire, and the audio profiles should work as expected.

I’ve tried that with no success:

I cannot install pulseaudio instead of pipewire because of dependencies with pulseaudio-bluetooth

I doubt it. I am using PulseAudio (not Pipewire) on Plasma Mobile and, as I have already written, it is similarly broken.

EDIT: Uh, actually both PulseAudio and Pipewire are running, huh? So which one is the system actually using?

This might help and clarify some things for you …

when I try the first proposal, this is what I get:

when I try the second proposal:

and the third:

so I finally don’t find the solution on that

but thanks so much for your help

I’m starting to think that the installation of any app (I don’t know which, maybe audiotube?) could make any dysfunction on the normal behavior of the sound configuration, because it is happening to me the same thing in the phosh system of another distribution. And, as I’ve been watching, the first clean installation the sound works perfectly.

The third command had a typo: comma rather than full stop in “pipewire.socket”

It would be easier to copy/paste terminal response instead of posting screenshots. People trying to help you would not have to type in responses. Text data can be indexed for web searches to help future users

Please post response to this command to show status of PulseAudio and PipeWire services

systemctl --global list-unit-files | grep -E 'pulse|wire' | awk '{ print $1,"\t",$2}'
1 Like

I know that, but I’m not able to copy text from terminal on Manjaro Phosh. If you know how to do it, please tell me.

In the meantime, I can only attach this:

1st proposal failed because pipewire-pulse has replaced pulseaudio

2nd proposal failed because wireplumber has replaced pipewire-media-session

3rd proposal failing due to typo was fortunate to leave PipeWire running

So I’ve been trying to do this:

systemctl --user disable --now pipewire.socket pipewire.service

correctly written and still no sollution.

Now the sound is even worse, because the speaker on top (where I listen conversation) isn’t working.

I’ve tried to uninstall all pipewire packages with no success because dependencies, and the same trying to uninstall pulseaudio.

So, is there a way for making work only pipewire or only pulseaudio like you advice??

Thanks for helping.

Screenshot in post#10 shows only PipeWire sockets/services

pipewire-pulse.service   disabled
pipewire-session-manager.service       alias
pipewire.service         disabled
wireplumber.serevice     enabled
pipewire-pulse.socket    enabled
pipewire.socket          enabled

Since PipeWire has replaced PulseAudio, command to disable pipewire.socket or pipewire.service is not needed.
I have recently found that pipewire.socket ignores disable command anyway, so it is not likely to cause problems.
If you were to revert to using PulseAudio I would now suggest masking pipewire.socket and pipewire.service to avoid hostilities

If you revert to using PulseAudio I may be able to help with further troubleshooting
But my knowledge of PipeWire is for defence purposes only
(not my circus, not my flying monkeys)

so how can I do this?

It should be possible to revert to PulseAudio using manjaro-pulse metapackage in similar manner to using manjaro-pipewire when changing to PipeWire

pamac remove manjaro-pipewire && pamac install manjaro-pulse

but pamac might stumble over PipeWire dependencies as beefore

If you cannot resolve dependency issues with the metapackage, install just the core PulseAudio package

pamac install pulseaudio

When pamac asks to choose optional dependencies, select pulseaudio-alsa only
Those 2 packages should be enough to check onboard audio for microphone/speakers and wired headsets
pulseaudio-bluetooth and any other optional dependencies needed can be installed once the main audio inputs and outputs are working as expected

I tried the first you told, and the result was failure because dependencies.

Then I tried installing pulseaudio packages and these are the options I get:


[manjaro@gonmovil ~]$ pamac install pulseaudio
Preparando...
Sincronización de bases de datos de paquetes...

Escoge las dependencias opcionales para pulseaudio:
1:  pulseaudio-zeroconf: Zeroconf support
2:  pulseaudio-lirc: IR (lirc) support
3:  pulseaudio-jack: Jack support
4:  pulseaudio-equalizer: Graphical equalizer
5:  pulseaudio-rtp: RTP and RAOP support

When I select one of them (I don’t know which is the best), then the same thing: imposible installing it because dependencies.

Please post full response from terminal to show dependencies causing problems. If the dependencies cannot be resolved, Manjaro Team will need relevant data to consider if any changes are needed for the metapackage

If metapackage manjaro-pulse works correctly, it should install:

  • pulseaudio core package
  • pulseaudio-alsa support for onboard audio and USB devices
  • pulseaudio-bluetooth for Bluetooth devices
  • pulseaudio-zeroconf for networked audio devices

I suspect there are dependency problems with pulseaudio-bluetooth but there is no data to confirm this

Since pulseaudio-alsa is not shown as an optional dependency I expect pamac might confirm it is installed as a recommended dependency during install of pulseaudio

When I select one of them (I don’t know which is the best)

I suggest you try selecting none of the 5 listed dependencies

The manjaro-pulse and manjaro-pipewire meta packages does not exist on the ARM side.

ARM section has been muted from my forum feed for a long time but I still get notifications if previous comments are quoted