PulseAudio issues, programs conflicting and only one will play audio

I’m having an issue where any time I try to use certain programs at the same time, only one will play audio, the either just doesn’t work at all or it’ll be entirely muted. It doesn’t happen often but when it does it drives me completely insane and I have been entirely unable to find a solution elsewhere and I’m at my wits end. The only thing I have seemingly been able to find out is that it apparently has something to do with either sample rates or PulseAudio, maybe ALSA but I’m unsure.

The only similar instances I’ve been able to find when looking this up are irrelevant as they involve specific circumstances that don’t apply to me at all. I’m completely lost at this point trying to solve this.
I think it’s something to do with something only working with one package at a time, but that’s as far as I’ve been able to get on my own.

provide formatted output from:
inxi -Fazy
click this icon in editor: </> and put the output there

If only one audio stream can play it is likely that the application creating the audio stream is bypassing PulseAudio and playing direct to a hardware device in ALSA
(an audio stream bypassing PulseAudio is not visible in desktop GUI audio controls)

ALSA can support multiple audio streams with a plugin, but applications are usually granted exclusive control of an audio device that blocks other audio streams
One of the raisons d’etre for PulseAudio was to allow playback of multiple audio streams

If PulseAudio is blocked from connecting to a device in ALSA, audio streams will still appear to play in audio GUI controls but will not be audible.
If all playback devices are inaccessible, PulseAudio creates a Dummy Output so audio playback is not blocked and applications do not crash or lock up system if audio playback fails

I suggest you first check audio settings for the applications taking exclusive control of ALSA
Ensure they are set to use PulseAudio (or default if PulseAudio is not listed alongside audio hardware devices) and check audio playback is visible in PulseAudio GUI controls

Then check any applications that fail to play audio direct to ALSA or cannot be seen playing audio in PulseAudio GUI controls and ensure they are set to use PulseAudio (or default)

  Kernel: 5.15.55-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=1968df18-222a-4bbf-bcd4-95818a0dd42e rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: EVGA product: N/A v: N/A serial: <superuser required>
    Chassis: type: 3 serial: <superuser required>
  Mobo: EVGA model: 131-SX-E295 v: 1.1 serial: <superuser required>
    UEFI: American Megatrends v: 1.08 date: 10/23/2017
  Info: model: Intel Core i7-7800X bits: 64 type: MT MCP arch: Skylake
    gen: core 7 process: Intel 14nm family: 6 model-id: 0x55 (85) stepping: 4
    microcode: 0x2006D05
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 6 MiB desc: 6x1024 KiB
    L3: 8.2 MiB desc: 1x8.2 MiB
  Speed (MHz): avg: 2832 high: 4176 min/max: 1200/4200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2259 2: 4176 3: 3706
    4: 3381 5: 1070 6: 3038 7: 3050 8: 3810 9: 3395 10: 2995 11: 1200 12: 1914
    bogomips: 84029
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Micro-Star MSI
    driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Pascal process: TSMC 16nm
    built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 65:00.0 chip-ID: 10de:1b80 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 96
    size: 509x286mm (20.04x11.26") diag: 584mm (22.99") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 515.57
    direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel bus-ID: 1-7:6 chip-ID: 1b1c:0a56
    bus-ID: 00:1f.3 class-ID: 0300 chip-ID: 8086:a2f0 class-ID: 0403
    serial: <filter>
  Device-2: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK CMI8786
    driver: snd_oxygen v: kernel bus-ID: 03:04.0 chip-ID: 13f6:8788
    class-ID: 0401
  Device-3: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 65:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-4: Corsair VOID ELITE USB Gaming Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.55-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.21 running: no
  Sound Server-4: PulseAudio v: 16.1 running: yes
  Sound Server-5: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Ethernet I219-V driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-3:4 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.82 TiB used: 587.47 GiB (31.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 587.47 GiB (32.1%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 52 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 39%
  Processes: 329 Uptime: 10m wakeups: 0 Memory: 31.05 GiB
  used: 4.19 GiB (13.5%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 1665 apt: 0
  pacman: 1653 lib: 392 flatpak: 0 snap: 12 Shell: Bash v: 5.1.16
  running-in: terminator inxi: 3.3.19

I think I stumbled upon something along these lines earlier, however I was unable to find out where to do any of this. If there’s supposed to be an option inside whichever programs I’m having issues with, none of them have any such option. If it’s something else then I’m lost.

My issue has not been resolved and it’s been almost two weeks with no replies. I am no closer to solving this issue than I was before.

try using pipewire instead of pulse:
sudo pacman -S manjaro-pipewire
it will give you pulse dependency issues, so remove them first, run the command again, select wireplumber, reboot and test

Please advise which applications are taking exclusive control of audio devices

System data shows both PulseAudio and PipeWire sound servers are running
Pipewire developers have recently advised that both sound servers running simultaneously will cause conflicts

FAQ · Wiki · PipeWire / pipewire · GitLab
running pulseaudio together with a PipeWire setup configured for audio is not supported (and will fail as both servers fight for devices).

I suggest you disable PipeWire server

systemctl --user disable --now pipewire.socket pipewire.service

and stop PulseAudio server

systemctl --user stop pulseaudio.socket pulseaudio.service

and check if the applications previously taking exclusive control of audio devices are still able to produce audio playing direct to ALSA

Then reboot system to restart PulseAudio without interference from PipeWire and check if all audio applications are working any better

If you could suggest using pamac to install Manjaro metapackages it would yield better information for Manjaro Team to consider improving either the metapackage or the package manager

I suspect pamac might be better at handling Manjaro metapackages, but cannot confirm this due to lack of data posted in topics

Once it can be established which packages are causing problems they can be removed before installing metapackage e.g.

pamac remove manjaro-pulse pulseaudio-bluetooth && pamac install manjaro-pipewire

Unfortunately, inxi only checks if a process named pipewire is running, it does not check if pipewire is (trying to) managing audio. One would need to inspect the output of pw-dump to determine that.

Yep, this did it. Thanks!

I wanted to remove Pulse in favor of PipeWire as a friend recommended that to me, but I had no idea how to go about that and I ended up overwhelming myself trying to find out. Didn’t give me an option to choose Wireplumber though, but I managed to solve that part myself easily enough.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.