Call for testers, Jade desktop

I tested Manjaro webdad 20.2 unstable in Virtualbox. That worked. I got it installed, but after the boot screen I only get a black screen. Bummer.

Can you post Xorg log so I can have look.

Xorg log
[    25.777] 
X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
[    25.777] Build Operating System: Linux Manjaro Linux
[    25.777] Current Operating System: Linux Jadeanjaro 5.8.18-1-MANJARO #1 SMP PREEMPT Sun Nov 1 14:10:04 UTC 2020 x86_64
[    25.777] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=5d5ec71e-2461-432a-8f02-aa012096b3e8 rw quiet splash apparmor=1 security=apparmor resume=UUID=e5b361aa-dd3c-4260-9c02-4eb807ed0a4b udev.log_priority=3
[    25.777] Build Date: 20 November 2020  09:03:19PM
[    25.777]  
[    25.777] Current version of pixman: 0.40.0
[    25.777] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    25.777] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.777] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 13 00:43:14 2021
[    25.801] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    25.801] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    25.818] (==) No Layout section.  Using the first Screen section.
[    25.818] (==) No screen section available. Using defaults.
[    25.818] (**) |-->Screen "Default Screen Section" (0)
[    25.818] (**) |   |-->Monitor "<default monitor>"
[    25.819] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    25.819] (==) Automatically adding devices
[    25.819] (==) Automatically enabling devices
[    25.819] (==) Automatically adding GPU devices
[    25.819] (==) Automatically binding GPU devices
[    25.819] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    25.828] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    25.828] 	Entry deleted from font path.
[    25.829] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[    25.829] 	Entry deleted from font path.
[    25.829] 	(Run 'mkfontdir' on "/usr/share/fonts/TTF").
[    25.829] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    25.829] 	Entry deleted from font path.
[    25.829] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    25.829] 	Entry deleted from font path.
[    25.829] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    25.829] 	Entry deleted from font path.
[    25.829] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    25.829] 	Entry deleted from font path.
[    25.829] (==) FontPath set to:
	
[    25.829] (==) ModulePath set to "/usr/lib/xorg/modules"
[    25.829] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    25.829] (II) Module ABI versions:
[    25.829] 	X.Org ANSI C Emulation: 0.4
[    25.829] 	X.Org Video Driver: 24.1
[    25.829] 	X.Org XInput driver : 24.1
[    25.829] 	X.Org Server Extension : 10.0
[    25.830] (++) using VT number 7

[    25.830] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    25.832] (II) xfree86: Adding drm device (/dev/dri/card0)
[    25.835] (--) PCI:*(0@0:2:0) 15ad:0405:15ad:0405 rev 0, Mem @ 0xe0000000/268435456, 0xf0000000/2097152, I/O @ 0x0000d000/16, BIOS @ 0x????????/131072
[    25.835] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    25.835] (II) LoadModule: "glx"
[    25.852] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    26.056] (II) Module glx: vendor="X.Org Foundation"
[    26.056] 	compiled for 1.20.9, module version = 1.0.0
[    26.056] 	ABI class: X.Org Server Extension, version 10.0
[    26.056] (==) Matched vmware as autoconfigured driver 0
[    26.056] (==) Matched modesetting as autoconfigured driver 1
[    26.056] (==) Matched fbdev as autoconfigured driver 2
[    26.056] (==) Matched vesa as autoconfigured driver 3
[    26.056] (==) Assigned the driver to the xf86ConfigLayout
[    26.056] (II) LoadModule: "vmware"
[    26.080] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[    27.512] (II) Module vmware: vendor="X.Org Foundation"
[    27.512] 	compiled for 1.20.8, module version = 13.3.0
[    27.512] 	Module class: X.Org Video Driver
[    27.512] 	ABI class: X.Org Video Driver, version 24.1
[    27.512] (II) LoadModule: "modesetting"
[    27.512] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    27.532] (II) Module modesetting: vendor="X.Org Foundation"
[    27.532] 	compiled for 1.20.9, module version = 1.20.9
[    27.532] 	Module class: X.Org Video Driver
[    27.532] 	ABI class: X.Org Video Driver, version 24.1
[    27.532] (II) LoadModule: "fbdev"
[    27.532] (WW) Warning, couldn't open module fbdev
[    27.532] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    27.532] (II) LoadModule: "vesa"
[    27.532] (WW) Warning, couldn't open module vesa
[    27.532] (EE) Failed to load module "vesa" (module does not exist, 0)
[    27.532] (II) vmware: driver for VMware SVGA: vmware0405, vmware0710
[    27.532] (II) modesetting: Driver for Modesetting Kernel Drivers: kms

Great work so far! Absolutely loving it so far. I have noticed a couple things however.

  1. Multi-Monitor Support. lxrandr does not like my triple monitor setup at all haha. I get some pretty crazy wallpaper distortions when moving the location (on left, on right, etc) of my monitors. I have one that I absolutely cannot move so I have to move my cursor across two monitors to reach. I’m sure I can tweak this and get it working properly, or just use a different tool instead of lxrandr.

  2. Wallpapering. For some reason I cannot get a wallpaper to apply to anything other than the default display. It would also be a “nice to have” to move the settings fly-out to a different display while maintaining the default display.

  3. This one may just be something I’m missing as I didn’t look for the solution super hard, but I’d like to disable the application fly out when the mouse reaches the top border or more hopefully disable the mouse boundary and have it set to a keybind. I accidently trigger that flyout so often.

Other than the monitor location issue and wallpaper issues this feels really good to use, I’m very much enjoying it.

Try to install xf86-video-vesa, xf86-video-fbdev or xf86-video-vmware, let me know which one is missing and I will add it to the image.

1 - Did you update? I have added multi-monitor support but only tested dual screen.

2 - wallpaper needs a fix as it will be bounded to the window manager instead of the application.

3 - I think I will be removing that in the future as it is a bit annoying the way is done now.

You can give them a different class name, using JavaScript or use nth-child selector.

Yeah I should be fully current. ISO was downloaded last night. I noticed a similar issue on another forum post with peppermint OS and lxrandr. The issue is I have three displays, dvi0, dv1, and hdmi0 (i think that was the naming convention). One has the position set to default and the option is greyed out. The other two I can adjust and move. I just can’t adjust the one that’s locked therefore I can’t get the positioning right. All in all it’s not that big of a deal, just an annoyance.

Not sure if you’re super interested, but I ended up finding a resolution for my monitor issues. I ended up installing arandr and saving a screen configuration and having that apply on startup. This worked perfectly other than borking wallpapers and positioning for the search placement and application flyout. Which I kinda expect to happen to a degree. I’m wondering if I can find a way to adapt the saved screen configuration from arandr and apply it to lxrandr. It seems like the application flyout and search function positions are dictated by the lxrandr configuration, so editing that directly will probably give me better results.

Sedang mengunggah Screenshot from 2021-01-15 09-53-28.png…

Sedang mengunggah Screenshot from 2021-01-15 09-50-26.png…

validity of what I did so that it did not work

VMWARE0405 is installed and working. I got it working by resizing the window I think. I think a large resolution is too much for it maybe…

What I found is that when I start Jade in text-mode then login and startx it does not show the bottom program shortcuts, incl. the menu:

It does show them when I startup normally.

Its not designed to run with startx.

1 Like

You most likely need to look on archwiki on how to configure xrandr for triple monitor.

I am always happy to help, but i would like very much for people to provide feedback and bug reports instead of software modifications, if something does not work then reading the documentation can help you overcome some coding difficulties.

https://www.w3schools.com/cssref/sel_nth-child.asp

#Applications:nth-child(3).app { something }

@eweee Usually the best way of doing things like this is to open the UI inspector under dev tools and play with the code live until it works, then when you are ready create a file in /home/username/.config/jade/theme/style.css

That way your changes won’t get overridden by any updates.