Calibre rendering issues in Wayland

I’m trying to configure Calibre, but all the preferences dialog are unusable, since they basically render a transparent window with some widgets in it.

Event taking a screenshot the Gnome Shell tool, doesn’t really capture what I see on the screen but a transparent one.

Any ideas?

Yes. According to your tittle:

Calibre rendering issues in Wayland

Personally, I think that :point_up_2: is the reason. If I’m wrong, then :man_shrugging:

(And it’s also according to me a demonstration of why Wayland is still not ready for prime-time.)

1 Like

However, I’m using Wayland for about a year now and calibre even before that. This is the first I come to this issue.

:man_shrugging:

I read ebooks on my tablet, so don’t know more than that.

I read them in a tablet, but I use Calibre as my organization tool. Actually, I’m trying to setup an “Open with” plugin to send books from Calibre to my tablet.

Let’s see if someone else has experienced this and fixed it.

1 Like

I can confirm the issue i.e. Calibre not redrawing its window under Wayland and KDE. I am seeing this when a minimized window is clicked on in the taskbar and only since a few weeks. Upon a mouse-drag on a corner the window is restored.
The same happens with some other Qt applications. So to me it looks like Qt is involved here. Have not found a solution yet. Searching on the internet does not show much on this.

1 Like

a first check is to open a console and start the app from the console. usually errors and warnings will be displayed. that’s always a good entry to get an image what’s not working.

I am throwing in a long shot here

I know that Python apps based on qt must implement a specific config to be able to display correctly on HiDPI - perhaps this is the case?

The app in question is entirely responsible for being HiDPI capable - which means if the issue is HiDPI related it is app related - not operating system

I’m daily using Calibre Editor and Viewer on KDE Wayland and don’t any problem with it, can you more clarify your problem with an attached picture ?

Yes, see below. What you see here, is a Transmission window (a Qt application) on top of a much larger Firefox window. In this window a small area (it is NOT a window) shows the actual content of the larger Transmission window. And the rest of this window is a copy of the covered underlying Firefox window or it is transparent(?).
As soon as I change the Transmission window size with a mouse drag, the small area completely fills the Transmission window. So then it is normal again.
I do not have a screenshot of a Calibre window. I rebooted my system and now can not reproduce this behaviour :face_with_raised_eyebrow:. Strange!

I installed transmission-qt and don’t see any problem while resizing its window.
I’m using iGPU, if this problem is always persistent, then report it to Plasma devs.

I will report here when it happens again. Thanks for your efforts!
edit nov 24 23 : it happens again. In my case it seem to be related to Espanso.
I am not the OP so I will not update this post anylonger.

Yes, KDE works great.


So don’t waste time with Wayland - it doesn’t have Mouse Gestures anyway!

Calibre’s working fine on my new Ryzen mini-PC’s Plasma Wayland (screenshot below). I didn’t have any issues with it on my old Intel PC either, which was also running Wayland for well over a year before it died last month.

Hi @medmedin

There’s an attached screenshot in the first post. You can see that most of the items in the settings are not being drawn.

Nevertheless, after an update, it works now:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.