Calamares possibly broken

calamares can’t install grub if root is f2fs works fine with ext4

Works fine. (tested in a VM)

/dev/vda2: LABEL_FATBOOT="NO_LABEL" LABEL="NO_LABEL" UUID="659B-8141" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="6a11bda5-401f-124b-b029-b088edb9f992"
/dev/vda1: UUID="878180bb-22b0-43dd-be61-449e6bcacb31" BLOCK_SIZE="4096" TYPE="f2fs" PARTUUID="8dc37303-c97a-5e4c-a0fe-de1d5d26486f"
sr0     11:0    1 1024M  0 rom  
vda    254:0    0   15G  0 disk 
├─vda1 254:1    0 14,8G  0 part /
└─vda2 254:2    0  200M  0 part /boot/efi

It’s typical calamares if root is f2fs calamares fails saying it can’t find /boot/efi which is fat32
If root is ext4 calamares works and /boot/efi is still fat32.

Strange - very strange - I have done several installs using f2fs - with no issues.

Is this a recent behavior - I mean - have you encountered before?

No it used to work and as an update the above is all with calamares.git but noted this is a month older than calamares so tried that and that does the same.
I also saw that yesterday @philm has merged upstream in, but its not out yet, so no idea if this will fix the problem?

Playing with something completely different I have build an ISO but with this topic in mind I deliberately chosed f2fs - just to verify your issue.

The non-git version of Calamares formats to f2fs without issues.

What can go wrong with the formatting could be if a filesystem exist - which explains why it works with a VirtualBox VM - as those are usually created from scratch using raw disk.

If Calamares executes mkfs.f2fs without the force argument on an existing filesystem - the format will fail.

So your issue - is it installing to a partition using reformat?

I’ve tried both and I think both failed I used to use gparted to format it first but recently let calamares do it I have tried both but maybe only with the git version If your sure it works I’ll try with the normal version.

I have only tested with VirtualBox - so you may be onto something - I will test it in a few minutes on bare-metal on existing filesystem.

Fwiw; I formatted that f2fs partition to ext4 and tried reinstalling again - back to f2fs, and it worked again (in QEMU).

Using manjaro-xfce-21.2.6-minimal-220416-linux515.iso with calamares 3.2.53-2.

The ISO I have played with is a very unusual variation

A GUI installer for a CLI only system :slight_smile:

I have booted bare metal - selected f2fs and the installer is just about to finish - no issues so far - rebooting - and done.

It doesn’t work with my full iso and I don’t really understand what @zbe is on about.
Will try a manjaro iso daily.

I must have tried everything last night and only your cli iso worked.
I decided to copy my iso to the usb stick and install it with ext4 as root, booted it and used gparted to wipe partitions left root as f2fs for one last try. It worked, I don’t think anything changed iso was the same therefore calamares was the same .

Both calamares and calamares-git have been updated to contain upstream 15/06/2022.
Calamares works and showed no sign of breaking.
Calamares-git whizzed through the install so fast it forgot to install grub. @philm