Caja missing server share and passwords not remembered

New here and to Manjaro but have been running Mint Mate for a while on my desktops. Looking to upgrage my home theater setup I settled on Manjaro Mate for some PI4’s (8G) whose main function are Kodi clients. These share a library served from a Synology DS1621+.

All runs well, but a few things I haven’t been able to sleuth outside of Kodi use…
Browse network’ only fiinds “Windows Network” (which goes nowhere) and doesn’t see the server.

Am I missing a module? I have looked… and looked.

I can manually connect to my server using the IP via smb from the file menu, which mounts the folder, and stays mounted until the unit is powered off.
I must enter my PW again even though I click “remember forever”.

I know the server is set up properly for sharing becuase:

On all my PC’s Mint Mate finds both:
‘server name’ (file sharing) and
"server name '(davs + sd),

I use the file sharing option, which shows the root of the server where I select a share and it is then mounted. At some point “forever” ago, I entered my server credentials and that was that.

So, for whatever reason Manjaro is not seeing my server, and not storing the passwords.
If it’s relevant, I auto-login at startup.
Much thanks!

For this have you installed caja-share and enabled avahi-daemon service?

Regarding passwords you likely need a keyring or password manager.

1 Like

That is relevant - as with autologin the keyring cannot be unlocked when necessary.

You can workaround it by using seahorse package to unlock the keyring permanently.

Thank you for your replies.
Some discovery going on here. First I found I needed to change hostnames. Confusing…
Correctly change the hostnames
So now with a #1 and #2

#1 had caja-share installed, #2 didn’t. ? Neither had Seahorse, and neither had the avahi-service started.

Starting the avahi-daemon revealed my server. Yesss!
which I can log into, though I have to enter credentials twice - once for root, another for shares.

I have put “systemctl start avahi-daemon.service” into startup applications with a 10s delay, which results in a password prompt at startup. It’s cludgey and I hope there’s a better way.
Not much experience writing scripts… Is that the right direction to look?

Passwords are still not remembered (no suprise), and think this has everything to do with leaving a keyring password blank soas not to be bothered with it. Works on the other machine… but that was years ago I set it up… Mint 18 or something… and Mint not Manjaro

Solid steps in the right direction, though. Thank you kindly. Will look at seahorse a bit later.

Pi #2 is a shambles. Not pingable yet has internet access. Caja-share wasn’t installed.
Lots of issues, so just going to junk it and start again rather than root through the weeds.
Want to clone #1 as an .ISO to save on headaches.

Is dd the best tool for this?

There is. Do:

sudo systemctl enable --now avahi-daemon.service

Yes. Take the SD card out of one Pi, DD it to an image file and flash it to the other SD afterwards. Just remember, both systems will be identical when you boot it up, so same IP, same hostname etc. So make sure you change stuff when you turn it on.

Thanks again. Can’t get to it today but will update when I do.

Did the trick, of course.

I will start fresh soas not to make temp files, browser history, etc… part of the base .img.
Need to amend the password issue first, so working on that.

Attempting to install Seahorse with the seahorse-caja extension on latest write results in:

Seahorse with seahorse-caja is not available for the aarch64 architecture
Wonderful… lol

This a dead end?

I looked at the AUR PKGBUILD and seems like you should be able to just add aarch64 to the arch() array and it should build fine.

Worked. Took a few tries.
I had an extra space or something. edit ** hit save
Then error message: install ‘mate-common’ – which took some time to build, but the suspense was worth it.

Seahorse works but appears much the same as before, whcih is to say I don’t see a default or login keyring as I do on Mint.

But reading the wiki…
edit** Logging into the server created a key. Reboot still nagged for cred.
I had to join the workgroup to get past that,

sudo nano /etc/samba/smb.conf

Edit the first line… and all is now golden.
Not very secure should little fingers get into it but I keep it up high…

Testing with dd.
My OS is on a 40G partition so want to send it elsewhere.
My sd card is 128G so shrank the partition to 15G to begin with.
Used lsblk to get the mount points for ‘if’ and ‘of’

sudo dd bs=4M if=/dev/sda of=/media/username/NewPartition/manjaro3.img
Lands in the right place, but filled (76G ) the partition.

Try to compress…
sudo dd bs=4M if=/dev/sda | gzip > /media/username/newpartition/manjaro3.img.gz
Same thing, but slower.

Do I need to shrink the volume in the first place?
Do I need a full 128G partition for the ‘if’?

If I had a smaller card laying around I’d use it, but there must be a way.

DD takes everything there is on the drive, including empty space. So if your source drive is 128GB, the resulting image will be 128 GB. You can of course compress it, after you made the image, like you would any file, which will shrink it considerably. But you can’t compress something, until you know the full size of it. That’s how compression tools, like gzip, works.

So, to do what you want to do, you need to be running the DD command from a device which has at least 135 GB of free storage space.

Edit - Solution possible with the replies through this thread:

I have an .img under 10G now. Another :heavy_check_mark:
Will I be able to write this to a 32G or 64G card?

Because login was a no-go for this application anyways:

I began again fresh with auto-login and this time, after enabling the AUR and running initial updates, installed mate-common (reboot), Seahorse, and Seahorse-caja right away.
Set the avahi-daemon service to start with:
sudo systemctl enable --now avahi-daemon.service

Then I tagged the server, which asked to create a keyring, which I left blank.
Confirmed with a second attempt.

I now have auto-login, enduring network access, and a viable install template for use on my internal network. Many thanks to Strit and linux-aarhus along the way.

Very helpful forum here.

1 Like

Yes. As long as the drive is larger than the file it can be flashed to it.

I see.
Thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.