Caffeine problems. (With a computer, not me)

Hi there.

I have Manjaro rolling release with Gnome desktop.

Caffeine has no icon at system tray or launcher panel, when it is activated.

I bookmarked/made it favorite to launcher panel to get an icon. However, there is no dot under icon, when Caffeine is active. Further, right click on icon does not give possibility to quit Caffeine.

Caffeine prevents computer for sleeping. I just do not know when it is active. Well, I know if I open System Monitor, but that is not meant to be that way, I think.

Caffeine presets works. I made presets for timeshift-launcher and deja-dup. When some of those are active, computer does not sleep.

  1. How to easily start and stop Caffeine for e.g. downloading a large file from internet?

  2. Is it common to make it start automatically, that I do not have to remember to start it when backup starts?

  3. When Caffeine activates itself because of preset e.g. during backup, should it de-activate itself after backup is made?

I found some commands from forum to put in terminal. I think that terminal has already an answer, I just do not understand it.

Found this thread Autostart caffeine-ng, but I do not find caffeine.desktop-file from autostart folder. That isKuvakaappaus 2021-09-15 00-05-06

be because I wanted to try not autostart.

The tray icon appears for me. Do you have the AppIndicator and KStatusNotifierItem Support extension enabled? It’s installed by default as gnome-shell-extension-appindicator.

Our caffeine-ng package no longer installs the /etc/xdg/autostart/caffeine.desktop file. If you want to enable it on startup, there’s an option in the preferences and a desktop file will be placed in ~/.config/autostart/.

Hi Yochanan.

I have gnome-shell-extension-appindicator installed.

Tray icon is visible for me to, because I found some command (I do not remember that anymore) to have that icon. But I had to bookmark/made it favorite, because icon did not appear again when Caffeine is started.

I use Kernel 5.4. With this one my laptop touch pad works.
System wanted me to use 5.13.

You merged this issue. Does it mean that it is investigated? I am just interested. I mean no hurry.

No, it means you should edit your previous post rather than posting twice in a row. :wink:

Since I can’t reproduce it and there are no related open issues upstream, there’s nothing to investigate at this point in time.

However, I just pushed an update that fixes this warning:

/usr/lib/python3.9/site-packages/caffeine/ PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.

It probably won’t help, but you never know.

EDIT: You do have the Show tray icon option enabled under Preferences, right?

I understand, partly. I can not be sure that I will not do a same again.

Probably I already received that update. After larger update came 2 smaller, but I did not noticed that Caffeine was mentioned.

However something has happened. Now I have Caffeine version 3.5.1+27+g1e5febf-1.
Error or warning message has changed:

This command freezes. I waited 2 minutes, nothing else did not happen.

I was able to start Caffeine with a help of favourite icon at a launcher bar. Because this is a result after I launched it:

I do remember that I had Show tray icon enabled under Preferences. However, Caffeine Preferences will not open anymore. It is visible in my computer in Applications. I do not even find it from Pamac Software Center anymore.

Off-topic posts removed.

I have less than one month old installation of Manjaro. I am surprised that this can not be solved.

New information is that when I try open Caffeine Preferences, sometimes Gnome Calculator is trying to open. I was able to take a screen recording of it.

I’m sorry I couldn’t be of more help. I can’t reproduce the issue and can’t find any related reports.

Trying to reproduce this behavior on a clean install. So far I’ve been able to not show the icon in the bar when disabling the AppIndicator extension, no gtk errors.

If another program opens when you start preferences this might indicate that something else is wrong.

One thing to try is to reinstall

pamac remove caffeine-ng
pamac install caffeine-ng

Then check in Tweaks of you can add Caffeine-ng to the startup applications?

I removed and installed again. No change.
I was able to add Caffeine-ng to the startup application. Then booted a computer. However, no change.

You was right, after all.

I just hope that you would adviced that “Open Extensions and check if there is AppIndicator and KStatusNotifierItem Support enabled”.
I didn’t find AppIndicator or KStatusNotifierItem by search query in Manjaro, so I thought that those are enabled, when I was able to find that gnome-shell-extension-appindicator is installed. Which I then confirmed to you.

I found this Extensions by accident. Right away I noticed that there was that setting what you meant.
I enabled it and now I have working Caffeine.

Great! Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.