Btrfs file system crashed during update, can no longer boot

I can no longer boot at all. I get through the bios loading screen which shows the logo for my motherboard, then instructions for entering bios menu/flashing, which disappears after about a second. After that its just the logo… Forever. Manjaro crashed during an update through pamac gui and it lead to this.
I’m currently on a live usb of Manjaro. I searched the forums and found threads with similar but different problems and the wiki page for restoring grub. I do not even know what the real problem is… I’ve seen in a thread the recommendation to do the update while in the live disk. Someone on a community manjaro discord also believe this is the problem so far. If I am to do that I am surely going to need help with mounting btrfs as seen: here and not ruining things even further.

Please help, I have no clue what I’m doing.

  1. Use the live USB of Manjaro again

  2. Check $ sudo lsblk -f to show where are your system partition and your ESP partition.

  3. $ sudo mount -o subvol=@ /dev/[sdaX or nvmeX] /mnt

  4. $ sudo mount /dev/[sdaY or nvmeY] /mnt/boot/efi (If you use GRUB)

  5. $ sudo mount -o subvol=@log /dev/[sdaX or nvmeX] /mnt/var/log

  6. $ sudo mount -o subvol=@cache /dev/[sdaX or nvmeX] /mnt/var/cache

  7. $ sudo manjaro-chroot /mnt

  8. Remove pacman lock file:
    # rm /var/lib/pacman/db.lck

  9. Update system again:
    # pacman -Syu

  10. Check to run
    # mkinitcpio -P, if it works?

  11. Update grub, if it works?
    # update-grub

  12. # exit

  13. $ reboot


This worked! Mostly I was concerned about the mounting and which partitions to mount. I still do not know if I use grub, and I ran into an error another user did in those forums of an error for mkdir /var/lock/dmraid and also there was no /var/lib/pacman/db.lock, only a local and system? file/folder(cant remember 2nd one exactly). For nvmeX I did partition 2 which according to the installer had the OS on it and partition 1 for boot/efi. I cant remember if it worked but if it didn’t I just continued anyway. Regardless of the errors I still booted and am in my main system. I’m going to restart a few times just to make sure it isn’t a fluke. If I don’t edit, that means everything works! Thank you so much, you have my gratitude. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.