Brother MFC-J6510DW printer won't connect to printer even with CUPS installed

Sorry If I’m a noob at this, but I’ve tried so many times to connect to my Brother MFC-J6510DW printer.
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.7-3-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-3210M CPU @ 2.50GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4000

At first I tried the brother’s own websites instructions, and used the console, but I had to install DPKG, installed it, but the PC doesn’t see the printer, so I installed the printer again using still it doesn’t connect, even when I try connecting it with usb://dev/usblp0, I can see the printer in the USB port, but CUPS doesn’t see it.

so I tried installing via using the ‘Internet Printing protocol’ using the printers IP address, still nothing, I’ve used, brother method, and I’ve install the same drives use the console method and a clone.
I’m out of idea’s here
I’ve also tried inputting network connection links like ipp://printer_ip/ipp/port1 and lpd://printer_ip/BINARY_P1

Still jack, is there a console config for the network I’m missing? I already know the IP of my printer, and I didn’t have this trouble stalling on KDE, before I had to replace a hdd drive, is the new Kernel that’s messing with me?
I’m also at the point of reinstalling KDE again, or using Arch if I can’t use my printer.

For starters, what is the output of:

systemctl status cups.service

The driver for that printer should be this (in AUR):

1 Like

● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: dis>
Active: active (running) since Sun 2021-01-24 09:51:34 GMT; 1 day 14h ago
TriggeredBy: ● cups.socket
● cups.path
Docs: man:cupsd(8)
Main PID: 659 (cupsd)
Status: “Scheduler is running…”
Tasks: 3 (limit: 9358)
Memory: 83.7M
CGroup: /system.slice/cups.service
├─ 659 /usr/bin/cupsd -l
├─ 1787 /usr/lib/cups/notifier/dbus dbus://
└─167392 lpd://printer_ip/BINARY_P1 29 user Test Page 1 job-uuid=urn:uuid>

Jan 24 09:51:27 user systemd[1]: Starting CUPS Scheduler…
Jan 24 09:51:34 user systemd[1]: Started CUPS Scheduler.
lines 1-17/17 (END)

Yeah that was the clone I used, and I used the IP method suggested in the comments too, still nothing

I just googled the printer name re Arch and found it in the AUR.
reading the (latest) comments on that page might provide useful info to you
… without that specific driver it probably wont work at all - as you discovered earlier :wink:
… it is (also) using the Debian (.deb) package you mentioned earlier
it is just … correctly installing it for you
you might have to remove/revert everything you did previously before this can work properly

Can someone explain if this has something to do with it? AUR (en) - brother-mfc-j6510dw

And how do I make the changes myself use PKGBUILD

That is the link I meant to provide along with my previous post and I think I indeed did …

Have you tried whether it works?
The comments read, to me, as if it should.
With some possible workaround in case it doesn’t.
I don’t see any (recent) comment re having to amend the PKGBUILD.

How to edit/amend a PKGBUILD is … covered elsewhere much more fully than could be done here.

… just look at it - the link to it is top right, below the heading, below “Package Actions”
it’s just a script describing where to get it, what to do, where to put stuff …

I installed my mfc-j8800-dw recently on a fresh install.

Make sure system-config-printer is installed. Turn the printer on & open print settings. (system-config-printer)

From there simply ‘add’ the printer. That’s it. Done & dusted.

That is the ideal/easy case.
That’ll only work if and when the correct/appropriate driver for the specific printer is installed/available
which it isn’t (by default) in this case :wink:
His/Her printer needs a driver only available from the AUR.


I tried that, it might be a error in coding in the PDD file, that the comment on the Arch website mentioned, Brother looks like they made that error when making that deb file

Your device URI: should be:

no effect

can you access your printer from browser:

I did get some strange warning from my console while I was searching for the server and the drivers

( Gtk-WARNING **: 03:05:55.386: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

( Gtk-WARNING **: 03:05:55.386: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

( Gtk-WARNING **: 03:05:55.386: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
/usr/share/system-config-printer/ DeprecationWarning: Gtk.ActionGroup.list_actions is deprecated
  for action in printer_manager_action_group.list_actions ():
/usr/share/system-config-printer/ DeprecationWarning: Gtk.Action.set_sensitive is deprecated
  action.set_sensitive (False)

No, the above address, can you access the printer from your browser?

@ theshadow6967

I’ve also installed the printer using this way.

Have a look at that topic.

I downloaded dpkg from package manager to use brother’s method at the start of all this, its one of the first things I did.
is ‘ysy -S dpkg’ any better?

no, I can not access it via my browser

… but, my man, that is not the same printer
and you’d only do it that way if the AUR didn’t have to offer a choice … which is really rare