Broken WiFi on RPi after 14 Jan 21 update

1 yes
2 done - it isn’t


What is the output of nmcli? Sorry if I am backtracking, I did not see it above.

Forgive me for being a little cautious about sending exact ip routing information over the forum - is it sufficient to say that both ethernet and wifi are connected to the router with the expected ip addresses?

If you have a specific request you could pm me.



This however is a little odd? Wifi contains this line


instead of the expected route4 which is the gateway (and which is listed under eth0).

When I go into NM to add a route, it asks me to enter an address for my ip, not the gateway address. My ip address is already added, but I added it again.

Any comment? or pm.

OK so today I have learned:

1 wpa_supplicant provides WPA security so can’t be masked or removed.

So I did

$ mv /etc/wpa_supplicant/wpa_supplicant.conf wpa_supplicant.bak.  

Now I can’t find it. But WPA still works.

2 dhcpd and NM don’t mix,

but in my case

$ systemctl status dhcpcd
Unit dhcpcd.service could not be found.

so I removed all dhpcd entries from firewalld and made a new NM connection.

None of this has worked.

BTW during my researches I am still puzzled by the lack of congruity between NM and firewalld (at least the systray applet, I don’t understand what the KDE Settings page means or how to change the settings).

For instance, I set the firewall to home in NM but firewalld ignores it. I set ports in firewalld but according to A-ip it makes no difference. Very frustrating.

Happy to execute any commands to see what may be happening.

I also found

but I really don’t want to reset the router as all the devices in the house hang off it and I would not be popular if they don’t reconnect. And everything else is working fine, it’s just Manjaro ARM wifi after the recent update. Manjaro x86 and x64 working fine.

(I also easily confirmed sudo -R - apologies for asking, it was late.)

My next step, if no-one thinks of anything overnight, is to reinstall Timeshift from cache and hope I can restore a working backup. I know I won’t learn anything if it works and that this could happen again (it’s already happened twice).

Any other ideas?


My apologies, I didn’t think there was sensitive information in the output because it is primarily a bunch of private IPs. Now that I look at it on mine, I honestly don’t know what to make of all the IPv6 addresses so I can understand where you are coming from.

This is normal. That is just announcing the network you are connected to. My network is the same actually:

route4 default via metric 600
route4 metric 600

The “inet4” is the IP of this computer. The line with “default” is the IP of my router. The last line is the IP range of the network.

When you scroll down to the DNS configuration, does it list the DNS server that you are expecting?

You definitely don’t need dhcpcd, not only because you are using NM but also because that device has a fixed IP address. It sounds like dhcpcd isn’t running or maybe isn’t even installed in the first place, so I guess that is not your problem.

Sorry I couldn’t be more helpful with this. I’ve been following the thread hoping to learn what the cause of this was, but it looks like you have everyone stumped! :man_shrugging:

Well I restored a snapshot - the only one which I could, which was not the latest before the problem - and the problem persists.

I ran nmcli again and this appears: it may have been there all along

p2p-dev-wlan0: disconnected
        wifi-p2p, hw

However, wlan0 is up and connected and showing a correct DNS address. I am seeing the same entries on A_ip - ie not seeing port 443.

Could the p2p issue (whatever it is) be the cause of the lack of internet connection?

It appears that timeshift (at least on ARM) is failing because it has to run as root and it uses Dolphin as file manager.

I found this in the Manjaro forums ;

But that didn’t work either. I managed despite error messages to get back to an earlier installation but no change to behaviour.

It’s not the router, been in there and checked. Or the pi, which works with other instances.