Broadcom BCM43228 Wi-Fi adapter driver issue

Hello team,

I would like to report a driver issue, with kernel 6.0.2-2

I use Manjaro Linux on my Dell Latidude E6420 laptop, and i noted that my Wi-fi stopped working with Linux Kernel 6.0.2-2.

What does anyone know anythiung if there is hardware support dropped from 2 Gen/ 3 Gen Core I hardware?

Hardware configuration is:

CPU: 2 gen Core I5, a decent 2 Gen Intel Core i7-2640M is purchased and in delivery

RAM: 4 GB ram Dual channel 2x2 GB, DDR3 1333, 16 GB ram for Dual channel 2x8 GB, DDR3 1333 is purchased and in delivery

BIOS verion: A26 - Newest available

Chipset: Intel QM67 Express, 6 series intel chipset

Wi-fi adapter: Broadcom BCM43228

I installed Manjaro Linux 21.3.7 with Kernel 5.15 - Wi-fi worked.
I updated to Manjaro Linux to 22.0.0 with Kernel 5.15 - Wi-fi worked.
I updated to Manjaro Linux 22.0.0 with Kernel 5.19.16 - Wi-fi worked.
I Updated to Manjaro Linux 22.0.0 with Kernel 6.0.2-2 - Wi9fi stopped working.

While making my troubleshooting, i made sure the laptop is online by connecting it with cable to my router. i also made sure that outside of the kernel, everything else is fully updated, I also made sure that Arch Repository was enabled, before begin to update, and updated the manjaro keyring, arch keyring, Updates databases, while still on 21.3.7 with kernel 5.15 so i can maximize my chances of getting something that i may otherwise miss.

I tried to manually remove the wi-fi driver, reboot, make clean install of the Wi-fi driver, the Wi-fi driver installs with errors, No reboot, Wi-Fi does not work, I rebooted, tried again, Wi-fi still does not work,

I tried the built in reinstall routine, it did uninstall and reinstall the driver, install goes with errors, No reboot, Wi-fi does not work. I rebooted, Wi-fi did not work.

please note: the laptop came with BIOS version A05, when i noticed the problem, and i was reverting to Kernel 5.19.16 where the Wi-Fi works Updated BIOS, to A06, tried again, 5.19.16 Wi-fi works, going to 6.0.2-2, wifi fails. I updated Bios to A08, same issue, same kernels, same behavior, next i went to bios version, same version swapping, same issues with same versions, then i went to A26, same results, same versions working, same versions failing.

While make all this dance with BIOS and Kernel versions i was using Manjaro Linux 22.0.0 with the 5.19.16 or 6.0.2 kernels with the same result between Kernel versions.

Do you have any advice or some guide, different than than reverting to kernel 5.19.16? Best result is if i can use it with Kernel 6.0 and Kernel 6.1 kernels.

Thank you,


Hi @Krisalex79,

Looking at This site, it seeems the adapter is only supported to kernel version 5.19. But it also states there is additional drivers that support the device:

And it would seem those drivers are in the community repository:

$ pamac search broadcom
broadcom-wl-dkms                                                                                                                                                                                                         community
Broadcom 802.11 Linux STA wireless driver

So installing it should be as easy as:

pamac build broadcom-wl-dkms

Followed by a reboot.

Hope this helps some!

Thank you for your suggestion, i will test it and give you feedback.

1 Like

you suggest that i should wait for some time before changing kernels?
looks like for now for now i will revert to Kernel 5.19.

Unless you need a feature specific too version 6, I always recommend sticking to an older LTS kernel. Version 5.15 or 5.10 specifically.

The community repository is enabled/allowed on my computer while i was troubleshooting on my own.

I tried the same exact commands, you posted, it displayed a lot of errors, but said transaction is successful. I rebooted, but wi-fi did not worked for me.

because it worked with kernel 5.19.16, I will revert temporarily to Linux kernel 5.19.16, until some reasonable development happens, so the laptop is online.

Until then, if something else happens or if there is new information, i will stay with 5.19 kernel.

Photo of the output:

i am open for ideas, suggestions and updates, whenever they become available.

Thank you team, for your efforts.

That error only specifies you need the headers for your kernel(s). They can be installed with:

pamac install $(pamac list --quiet --installed | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

This will install the headers for all installed kernels.

But there are still no guarantees the wireless will work.

Ok team, one last question.

I installed kernel 5.19.16

My goal now is to set Manjaro Linux to boot with Kerlen 5.19.16, and once manjaro boots with kernel 5.19.16, to remove kernel 6.0.2, until further development of the case and kernels and driver.

After this last issue is resolved, the topic can be archived for a better day in the future :slight_smile:


  1. Install version 5.19:
mhwd-kernel --install linux519

Or, as I suggested, linux515.

  1. Reboot into the newly installed kernel.

  2. Remove version 6:

mhwd-kernel --remove linux60

Hope this helps!

1 Like

i will try this before reverting. Thank you again.

I already have the kernel installed.
How to make the switch kernels itself? How to tell Manjaro boot using this kernel, specifying the desired kernel?

When your computer is starting, during the BIOS/UEFI screen when you are informed to PressKey to enter setup, or something in that line, press/SPAM the Esc and/or Ctrl keys, to make the grub boot loader appear. (It’s hidden by default.)

On the grub menu, use Up and Down arrow keys to navigate to the Advanced… option, and press Enter to enter it.

On that screen, use the Up and Down arrows to select the kernel version to boot into.

Hope this helps!

Some more info …

The preferable way to get working on kernel 6.0 would be

pamac install linux60-broadcom-wl

But this package is broken, see [Stable Update] 2022-10-10 - Kernels, Octopi, Deepin, GlibC, Haskell, Python; Nvidia 520.56.06 - #99 by mishmosh

Package broadcom-wl-dkms hasn’t got the needed code changes in it yet, so fails to compile with linux60-headers.

The dkms package can be hacked to get compiled and working, and seems stable for me for the last 5 days, although I don’t use roaming so I can’t comment on that aspect.

Details of that hack in [Stable Update] 2022-10-10 - Kernels, Octopi, Deepin, GlibC, Haskell, Python; Nvidia 520.56.06 - #53 by mishmosh

Obviously its not a recommended way to go about it, but I think it demonstrates compatibility with kernel 6.0 :slight_smile:

EDIT - better workaround in

Ok i will try this, but how to remove the -dkms version? it makes conflict with the non -dkms version

pamac remove broadcom-wl-dkms

I expect it to break for you as well :stuck_out_tongue:

1 Like

well so far all advice how to make it work on kernel failed.

  1. installing the kernel 6.0 headers and reboot

  2. installing the -dkms version and reboot - did not worked

  3. removing the -dkms reboot, install the linux60-broadcom-wl, reboot, did not worked.

I will revert to 5.19.16. Please wait for further feedback.


Well, i reverted back to Linux kernel 5.19.16 on my laptop, now it works, and i am happy that it works. this is where i am going to stay for a long-long time on the laptop. Truth is i wanted 6.0 kernel for the performance improvements it brings, but it is what it is.

Once again, if you want to keep it, as you say, a long-long time, I suggest an LTS kernel. Because that is Long Term Support. and 5.19 isn’t, so it’ll go EOL sooner, disapear from the repositories sooner, and you’ll end up having to replace it much sooner, just to have a working system. But I’ll stop bugging you now.


1 Like