Brightness resets to 0 after every reboot

And now the error Failed to start Load/Save #tness of backlight:acpi_video0 shows up again

Okay, mask it again :rofl:

sudo systemctl mask acpi_video0


Ok but I don’t see the point
The brightness issue still exists :joy:

My apologize, I am out of ideas for now :confused:

Sorry I didn’t mean to be offensive
Thanks for your help :slight_smile:
At least, the errors don’t show up :smiley:

1 Like

Oh, no worries, was not offensive :grinning_face_with_smiling_eyes:!

I will try to come up with a solution soon!

1 Like

Thanks so much for your help
I can write a script to run on every boot but I really wanna know what the problem is

1 Like


I thought of something!
Try to add this whole line to grub!!

acpi_backlight=native radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 systemd.unified_cgroup_hierarchy=0

Thanks but that didn’t help as well
Now I’m really confused what the problem might be :thinking:

Hi, i have same problem. I haven’t the same system specs of yours, but i have also a amd laptop.

I have fixed the errors only with this in kernel58 and all the errors are gone:

But still, my brightness is set to 100% after every reboot :frowning:
maybe this works?? I haven’t tried:

Have you also the failed error in the status service of amdgpu_bl0 btw??
systemctl status systemd-backlight@backlight:amdgpu_bl0.service

I have also found this:
I think the bug is fixed in kernel59 (i haven’t tried). Its a experimental version, but its RC6, maybe you can trust.

Or you can try this:

 John Shand 2020-09-08 00:59:17 UTC

i have had this problem as well. was recently working well with kernel 5.8.7. i then install ucode-amd and then grub-mkconfig -o /boot/grub/grub.cfg to set the changes. grub automatically made the new code image work with initramfs and then, backlight went back to about 20% or 255.

i won’t to try, i’m to scare to brok something :frowning:

oh, no worries! It shouldn’t break anything!

It is just the micro codes for the CPU, and if it is not compatible, it will be ignored!

Oops yeah, the package ucode amd is already installed :stuck_out_tongue:

I think kernel59 is the only fix what we need. Who give it a try? :smiley:

I am on kernel59, and seems to bo relatively stable for me! :sweat_smile:

But your mileage may vary.

Before i install kernel 59, i have tried this:

maybe this works?? I haven’t tried:

But the tutorial is incomplete! After start/enabled the script as service unit i have a error that the brightness 0 is to low, i must set to 2 and i have tried to set the 0 in the file to 2, but its go back to 0 after every reboot :unamused:

Damned! I tried kernel 59 = same problem! :face_with_symbols_over_mouth: :rage: :japanese_ogre: :japanese_goblin:

Its really not easy to fix this.

Wow! I found a working WORKAROUND for everybody that reset the brightness to 0 after every reboot! Its really easy, without scripts, etc. Its not perfect, but for now its good enough for me. It works with xfce, but i’m sure that its works also with kde as you know where the options are.

This is what you need do to (in xfce):

  1. Go to the settings of xfce power manager
  2. Go to tab display
  3. Set the inactivity in accu on 10 sec and 10% brighness. Same with power.
  4. Set the main brightness a littlebit higher, try to set to 11% NOT lower or same as 10% or else it won’t work!
  5. Reboot and after reboot you need to wait 10 seconds extra. Bam you are inactive and the screen go to 10%,
  6. Touch the laptop and BAM 11% brightness!

It works nice for me and i can wait for the real fix from the devs. :crazy_face:

What in the quantum processing unit-

:rofl: Okay!

I think the issue was potentially introduced by some Mesa update a couple of weeks back.
At least that is when I started to notice it on my (AMD) laptop.
Laptop would not remember screen brightness after a reboot and 1st time I wanted to change it, it would act wonky, i.e. go to 0% brightness (but it would work fine after).

What I did is somewhat similar to freestuyso’s workaround:
I went to KDE’s power saving settings (in System settings -> power management).
There I set the screen brightness to whatever I want for (low) battery & AC Power, respectively.
As a result the laptop boots into a sensible brightness setting and I can reliably&directly change it, if necessary.

I thought that i was the only person on the earth that i found the workaround… and now you tell this…
Why you don’t say that before i trying all-that-not-working-solutions? :cold_sweat:

Guess because I didn’t know until yesterday when I stumbled upon this topic? :wink:

Although I had read about the issue some time ago in a different thread, shortly after the respective update had dropped, which led me to applying the workaround back then.