Brightness resets to 0 after every reboot

Hello everyone
Every time I reboot my laptop, it first displays something like this line of error:

FAILED to start Load/Save of backlight:acpi_video0

And then my system boots with 100% brightness
After a few seconds, it resets to the lowest setting
My specs:

System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 
           dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A serial: <superuser/root required> 
           Chassis: type: 10 serial: <superuser/root required> 
           Mobo: HP model: 87B1 v: 31.17 serial: <superuser/root required> UEFI: AMI v: F.02 date: 05/14/2020 
Battery:   ID-1: BAT0 charge: 11.5 Wh condition: 51.4/51.4 Wh (100%) volts: 11.0/11.6 model: Hewlett-Packard Primary 
           type: Li-ion serial: N/A status: Discharging cycles: 462 
CPU:       Topology: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71896 
           Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1394 5: 1398 
           6: 1397 7: 1395 8: 1392 9: 1400 10: 1397 11: 1390 12: 1393 
Graphics:  Device-1: NVIDIA TU117M vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0 chip ID: 10de:1f99 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 05:00.0 
           chip ID: 1002:1636 
           Device-3: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB driver: uvcvideo bus ID: 3-3:3 
           chip ID: 30c9:0013 serial: 0001 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: AMD RENOIR (DRM 3.38.0 5.8.11-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: snd_rn_pci_acp3x v: kernel bus ID: 05:00.5 chip ID: 1022:15e2 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 05:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: b0:5c:da:42:34:3f 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8822ce 
           v: N/A port: d000 bus ID: 03:00.0 chip ID: 10ec:c822 
           IF: wlo1 state: up mac: 70:66:55:bb:04:b7 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: 00:50:56:c0:00:01 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: 00:50:56:c0:00:08 
Drives:    Local Storage: total: 476.94 GiB used: 248.83 GiB (52.2%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNV512G KIOXIA size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: 306PEEC9PBV1 rev: HP00AE00 scheme: GPT 
Partition: ID-1: / size: 459.50 GiB used: 248.83 GiB (54.2%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 37.5 C mobo: N/A gpu: amdgpu temp: 37 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 288 Uptime: 12m Memory: 7.21 GiB used: 1.79 GiB (24.8%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1448 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

Howdy!

Could you please open a terminal then type in sudo nano /etc/default/grub please?

Once in the editor, use the arrows key on your keyboard to navigate toward the line where it says GRUB_CMDLINE_LINUX_DEFAULT=
Then add acpi_backlight=vendor to the end, but befor the last " (quotation mark)!

Hit CTRL + S to save, then CTRL + X to exit the editor.

Finally, punch in sudo update-grub

Reboot!

Have a wonderful day! :sweat_smile:

Heyy
Thanks for your help
This is my grub now:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=d2ac6ecc-cb0e-4f82-b617-1792c08b94b3 udev.log_priority=3 acpi_backlight=vendor"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

The problem still exists

Howdy!

Could you please provide me the output of ls /sys/class/backlight please?

Thank you!

Heyyy
Yes of course

amdgpu_bl0

Wow that’s the exact thing I see in error when I boot my laptop
And also these are inside amdgpu_bl0 :

-r--r--r-- 1 root root 4096 Oct  5 14:25 actual_brightness
-rw-r--r-- 1 root root 4096 Oct  5 14:25 bl_power
-rw-r--r-- 1 root root 4096 Oct  5 14:04 brightness
lrwxrwxrwx 1 root root    0 Oct  5 14:25 device -> ../../../0000:05:00.0
-r--r--r-- 1 root root 4096 Oct  5 13:36 max_brightness
drwxr-xr-x 2 root root    0 Oct  5 14:25 power
-r--r--r-- 1 root root 4096 Oct  5 14:25 scale
lrwxrwxrwx 1 root root    0 Oct  5 13:36 subsystem -> ../../../../../../class/backlight
-r--r--r-- 1 root root 4096 Oct  5 13:36 type
-rw-r--r-- 1 root root 4096 Oct  5 13:36 uevent

Thank you!

Instead of acpi_backlight=vendor in your grub configuration, please change it to acpi_backlight=amdgpu_bl0 !

May also mask the acpi_video0 by imploring sudo systemctl mask acpi_video0

Hope that may help!

Ok now it got worse :joy:
Away from the brightness set to 100% every time, the errors I see when booting are:

Failed to start Load/Save #tness of backlight:amdgpu_bl0
Failed to start Load/Save #tness of backlight:acpi_video0


Edit:

I changed acpi_backlight to native based on this question and the error Failed to start Load/Save #tness of backlight:acpi_video0 vanished.
But I still see amdgpu_bl0

Oh no :joy:

Might as well try to mask amdgpu as well, see if it does something…

sudo systemctl mask amdgpu_bl0

I run it and restarted but still no result
Also my brightness problem is still there :smiley:

Hmmm :thinking:

Lets try to sudo systemctl unmask acpi_video0 , then set acpi_backlight=video0 in grub …

Again, those two errors showed up
What’s the problem?

Have you ran sudo update-grub , may I ask?

Yes I ran it and restarted :slight_smile:

Alright, sudo systemctl unmask amdgpu_b10 then add acpi_osi=Linux acpi_backlight=vendor to your grub config. :thinking:

Unfortunately, the problem still exists :frowning_face:
I mean both error on boot and brightness issue

Okay, could you please roll back to kernel57, see if thats the issue?

Ok now my kernel is:
5.7.19-2-MANJARO
And the error on boot disappeared(Thanks!!)
But still, my brightness is set to 100%

Hm, then lets remove acpi_osi=Linux from grub, and change to acpi_backlight=native :smile:

Still no chance :joy:
I guess grub is getting angry with me :joy:

Hm, getting out of ideas😬

Try to completely remove the acpi backlight string in grub…