Brawlhalla not running in Proton and really slow in WINE (Steam)


I’m having trouble with running Brawlhalla in steam.

Firstly I tried to enable proton (~4.11) and run it that way. Unfortunately it does not launch, stuck in an infinite loop of updating. This game works on a slower laptop running ubuntu.

I then tried running Brawlhalla through WINE. This launches, but there are frequent frame dips in performance (I have a slower iMac that runs this better).

Does anyone have any tips on how to get this to work?

Brawlhalla works through WINE in Ubuntu (same computer), however, proton on ubuntu does not run.

My specs are:

Intel i5-2500k
Radeon HD 6950 (2GB)

I’m running Manjaro GNOME 20.1 on an SSD.

Thanks in advance!

Have you tried using Proton 5.0-9 or later?

I used Proton ~4.11 because people said there were issues with proton 5<

I’ll give it a go with some of the arguments at any case. I’ll report back soon.

The ProtonDB page shows what others have done to have it to work, try to change your game startup parameter in Steam, right click the game, properties, startup parameter. using Proton 5.0 or 5.13:

PROTON_USE_WINED3D=1 %command%

Yeah, I’ll probably give that a go before the end of the day to see Whether we can get it to run.

I did just remember that I did try with proton 5-9-0 (without any of the arguments), and that didn’t launch either (stuck in an infinite updating loop).

I’ll report back soon.

What do you call an infinite updating loop.

I tried showing sreenshots, but alas, it won’t let me.

I click play, and then steam says Brawlhalla is updating. This never finishes.

I tried a different version of proton. No such luck.

use the code </> button to share a link if you don’t have permission yet to post images and link, select your link and click the button, like this:


This is what I mean:

How about you wait long time to see if it finishes updating then? You can check the network activity to see if it downloads anything or not too during that time.

Also you can verify the game files in Steam Verify Integrity of Game Files - How To's - Knowledge Base - Steam Support

You can try to reset the Proton prefix if it has an error it may help ( Delete (or rename for backup) the Proton prefix for this game, located at ~/.local/share/Steam/steamapps/compatdata/ {APP_ID} / where {APP_ID} is the Steam application ID, in theory for your game it is 291550)

You can also try to clear Steam download cache Clear download cache - How To's - Knowledge Base - Steam Support

Tried this. I left it overnight, and it still hadn’t changed from where I left it.

The “Preparing to launch” issue might be more related to Steam itself, since other games have had the same problem. Maybe adapting a solution from one of such games would fix yours.

Not against you, but I recently replied multiple threads like yours it is always the same, I suggest multiple things, and every time I have a reply, it is a vague undescriptive one, always forcing me to dig myself and ask the same unneeded questions, this is annoying.

What did you try which did not work? from your reply you just tried to let it sit overnight? If so, what about the prefix reset? or the Steam cache clearing? or the startup parameters? the different Proton version after cleaning everything?

See you never replied to that what’s the point of me asking anything, trying to troubleshoot YOUR problems?

@omano Sorry, I do apologise. I’ll try better.

I left it “updating” overnight. No network activity, no finished update.
I have tried with startup parameters, and without (PROTON_USE_WINE3D). No luck.
I haven’t tried clearing the cache. I’ll try that next. Prefix reset?

I’ve never really dug into how steam works, (or really run games in Linux for that matter), so please forgive my vague replies. There are just some things I don’t know about.

Anyway, I’m going to be running windows on a separate drive, and run games on there, until I have found a fix for Manjaro.

No need to appologize but it is frustrating I feel like people don’t even read. So


It can solve issue if the issue lies in the Proton folder for this specific game, as after deleting (or renaming for backup) the specific Proton game folder, it will create a fresh one when you’ll start the game after.

I understand not everyone is computer savy, and what I think is very simple to follow can be challenging for others. No hard feeling, just that with multiple forums cumulated where I try to help it is always the same story and it’s very frustrating, from my point of view.

I’m just going to check with you (I might not have setup proton properly)…

You go into steam -> settings -> Steamplay -> Force Steam Compatibility tool or something like that, and select proton xxxxx, right? That’s all you do? Or have I missed a step?

Yep, unless you also forced a Proton version in the game Properties, this is all that is needed to change Proton version.

And I’m right in thinking I don’t need to install anything for this to work?

I’ll probably clear Steam cache, and report back when I’ve done that.

No Steam should take care of everything when changing a Proton version, if you don’t have it yet downloaded it will download it.

Great, sorry for the noobish comments, but I just wanted to check that I hadn’t missed something.