Brave not working proper after today's Update

I have been using Brave browser since last 6 months and it was working properly. After today’s update
when writing anything on address bar the display gets messed up. And sometimes event the content does some weird glitches.

I am on Manjaro Gnome Stable (I have enabled brave:://flags for wayland)

Brave version :
Version 1.52.117 Chromium: 114.0.5735.90 (Official Build) (64-bit)

I use Brave on my other computer which is on Arch, using Hyprland and it works without any problems

Any ideas how to fix this ?

1 Like

Try running it in terminal like this:

brave -use-gl=egl

I also have this issue on manjaro KDE stable. Updated to 1.52.117-2, rebooted, and poof! all my tabs are screwed.

I temporarily fixed it by switching to brave-browser-beta and using grsync to copy my cache and settings:
~/.cache/BraveSoftware/Brave-Browser/ to ~/.cache/BraveSoftware/Brave-Browser-Beta/
~/.config/BraveSoftware/Brave-Browser/ to ~/.config/BraveSoftware/Brave-Browser-Beta/

I initially tried downgrading to an old version of brave-browser, but that didn’t help for some reason.

This worked for me, thanks!. Is there a way to configure brave to launch with this option when started through the GUI?

You can make use of


Thanks for the suggestion. Creating


and filling it in with

brave -use-gl=egl

appears to have fixed the normal mainline version of brave browser. I appreciate the help!

Glad to help.

The file takes flags just like chromium-flags.conf … there is no need for brave term in that file.

Note for amd users:
egl is often broken … likely you may prefer to use angle

Note for everyone:
Probably look into hardware acceleration

…did nothing. I think restarting your PC and/or your browser is what actually solved your issue. :wink:

It should be:


You’ll either need to restart Brave twice or completely close and open it again for it take effect. You can verify the flags in use going to brave://gpu and looking at Command Line under Version Information.

EDIT: I’m pretty sure that flag is deprecated and no longer does anything for hardware acceleration.

Also the Arch wiki says,

Setting this option might no longer be needed when using Chrome 112 and may break GPU acceleration when using AMD GPUs.

Chromium - ArchWiki

this seems to be working but it is even worse because now if I want to open a new window it does not open . it tries to open a tab on the existing window. I have typically one Brave instance open on one workspace and have another one on another workspace and that flag breaks it . It fixed the address bar thing.

My point is Brave works with Wayland with no problems like that. I use it on Arch with Hyprland which is wayland compositor. So the problem there is some setting here that is causing it. But I dont know what it is . and it was working until this update.

So to me that flag is not the solution. Any other solutions :frowning: I also notice discord display is messed up too. :frowning:

You note that egl is often broken for AMD hardware (yay) and angle is an alternative. Is that as easy as:

pamac remove egl

pamac install angle


That Arch page you linked didn’t mention egl or angle once.

This page GitHub - google/angle: A conformant OpenGL ES implementation for Windows, Mac, Linux, iOS and Android. suggests you need to rebuild your project with angle instead of egl… So how do I get the Google Chrome source to rebuild it?

no …

--use-gl=angle instead of --use-gl=egl

this did not work for me . I put it into brave-flags.conf
but no effect at all. I know tons of people using Brave with Wayland with AMD no problems like that. and it was working here too

I only mentioned it in the context of use-gl=egl/desktop … which usually indicates the user is already engaged in configuring hardware-acceleration … meaning it is rarely the only flag used.
I also cant speak directly to brave in any way because … well you couldnt pay me to use it :stuck_out_tongue_winking_eye:

Example of my chromium flags

you use x11 for


I had wayland enabled and it was working. and it is working on my other computer. Not sure why iit is not the working here.

So I opened brave://flags changed the --ozone-platform-hint=auto and Brave relaunced closing and reopening then everythng worked. When I rebooted my computer it was broken again. Then again I change the same setting to Wayland and Brave relaunched and it started working normal again.
That is weird. really weird :slight_smile:

another thing. if switch Gnome Classic in the display manager then Brave works . so that must some Manjaro Specific settings is somehow causing this issue see the screen shot the address bar works
with Gnome classic ;

06/04/2023 update last night, hyperlinks take over 1 min to open in brave from Manjauro help, Telegram, Thinderbird etc, apps from task bar (panel) yes I am new to Manjaro and Linux but not pc’s, take over 1 min to launch or won’t open at all, i.e. Proton VPN GUI. Network settings say I am connected but it won’t open to configure or make changes. Current kernel. What happened?

congrats … you are the 987987th person to ignore the dozen or so places thats been mentioned and responded to with “the ‘xdg-desktop-portal-gnome’ bug”.

Its generally not a great idea to hijack other threads … in this case a bit of searching/reading yourself would have stopped you from needing to post at all.

Hello fellow Manjaro Users:

I am also experiencing issues with Brave and Google Chrome GUI interfaces.

I had issues with adding a brave-flags.config file to ~/.config. in xfce with AMD and Nvidia. So I opted to look for a less dramatic solution path. I’m use xfce with a gaming notebook that uses an AMD cpu, video, and an Nvidia 2060. I hate messing with stuff in /home/ (user) /.config. Messing with stuff in there without having full backups and a wealth of reference materials close at hand. To avoid that obvious challenge. My solution suggestion are quick cheap hacks!

For Brave:
I adjusted the xfce Brave launcher changing the command to: " brave --use-gl=egl %U ". Without the quotes. It’s a cheap way to avoid messing around inside /home//.config and potentially introducing new headaches.

For Google Chrome:
I did the same with the launcher for Google Chrome command: " /usr/bin/google-chrome-stable --use-gl=egl %U ", again without the quotes.

I assume a future update or patch will fix the present issues.

This hack fixed my issues with the Google chrome and Brave GUI interfaces. Until the next batch of updates; enjoy!

Usually people would copy the .desktop file to home (~/.local/share/applications) and edit that.
If you edited the system file … it will be overwritten on update.
And editing this way requires root.

I dont really see this as ‘easier’ … or ‘less difficult/dangerous’.

It is better, easier, and will actually last if you use the flags method.

Though … once again … its worth noting that the flag itself should only be used in conjunction with properly configuring hardware-acceleration … as in it likely should not be the only option used … otherwise users should simply disable the chrome option for hardware acceleration in its settings, which will also ‘fix’ the issue.

Thank you.