Brave installed but not starting

I managed to install this web browser from snapd. Unfortunately it doesn’t start. Even if I already enabled apparmour. What am I doing wrong?

Is there a reason you want to use snap in particular?
How did you do the install?
What happens when you try to launch?
Maybe include the output from trying to start in terminal.

Well because I did it so the last time and it worked. Should I have used yay? I get no output because I’m starting it from the interface not from the terminal…

There were just 2 snapd warnings… They asked me to enable snapd’s apparmour… Otherwise the apps won’t start…

yay does not handle Snaps or FlatPaks. It’s an AUR helper for pacman. :wink:

If the Snap for brave doesn’t work, try the version from the repository instead.

But by the way… :arrow_down:

As far as I know, this requires a reboot.

So install the helper and then use it to install the browser… And what should I do with the old one? Uninstall it?

yay will already be installed, normally. But you don’t need it. Just uninstall the Snap package and then install brave-browser via pacman from the repo. :arrow_down:

sudo pacman -Syu brave-browser

You wouldnt need to install anything extra as brave-browser is in the repositories.

If you dont have any particular reason to use SNAP, or dont know what it is … then, IMHO, you should likely avoid it and even remove it entirely as it would be bloat that takes up inordinate amounts of space, slows boot, and will cause extra headaches when you realize things like it not being integrated in the native filesystem.

I thought it wasn’t in the repo anymore… Since a couple of years ago… This is why I used this method…

The interface shows that it takes just 62 MB… However log revealed that those dependencies or however they are called took another 1 gigabyte. Installation was tedious… It kept running in a loop verifying and reinstalling some things… And then verifying and starting again and so on…

I guess this think you mentioned that it’s not in the native file system… This must be the cause for that decentered logo by start-up. It just jumps top right and then gets back again.

damn! Now the add remove software from the interface is not starting… I get 2 failure messages…

Message recipient disconnected from message bus without replying

Did not receive a reply possible causes include the remote application did not send a reply to message bus security policy blocked the reply the reply timeout expired or the network connection was broken.

I eventually got rid of snapd but… When trying to install brave from the repo I get target not found…

Don’t use that GUI. Use the command line.

Your database is probably not up to date — maybe your system isn’t either. :arrow_down:

sudo pacman-mirrors -f && sudo pacman -Syyu brave-browser

Howcome you find brave in the repo and I get this error message… Which one are you using?

Well… It checked the mirrors and I still get target not found…

I think there might be something amiss with your internet connection then. Possibly an intermittent connection. :thinking:

Maybe the domain is not set? I mean left undefined… The log shows me that it downloads the core extra and community package databases and then I get this error…

There no longer is a Community repository. It was merged into the Extra repository three months ago.

Somebody hasn’t been merging their .pacnew files… :face_with_raised_eyebrow:

Okay, try this first then… :arrow_down:

sudo pacman -Fyy

Where can I find this in the menu?

This one worked now all of the package databases are up-to-date


Now install it… :arrow_down:

sudo pacman -Syu brave-browser

What exactly do I have to do? Edit some file?

Unfortunately even after the update I still get that error… target not found