Brave can't share screen

Hello Everyone,

I just switched to Manjaro recently, however, I encountered an issue in which I was not able to share screens in Discord and Google Meet with Brave browser. Below attached with the version and package which I’m currently using.

Manjaro Version: 22.1.0
Gnome Version: 43.4

Hi @XinJ, and welcome!

:point_up_2: This might be the reason, I don’t know - I don’t use Wayland. I do know, however, that Wayland still has numerous “issues” like this. So maybe it’ll work with X11…

Does it works properly with Firefox for example?
I think hardware acceleration can cause issues with screen sharing. Try disabling hardware acceleration in Brave by going to Settings > Additional Settings > System > Use hardware acceleration when available, and toggling the switch off

You need 3 things:

  1. pipewire, install it with:
pamac install manjaro-pipewire
  1. enabled enable-webrtc-pipewire-capturer flag in Brave brave://flags/#enable-webrtc-pipewire-capturer
  2. enabled Hangouts in Brave settings brave://settings/extensions


I couldn’t run

pamac install manjaro-pipewire

I’m getting the error below:

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: user
Synchronizing package databases...
Refreshing core.db...                                                           
Refreshing extra.db...                                                          
Refreshing community.db...                                                      
Refreshing multilib.db...                                                       
Error: multilib.db: GPGME error: No data                                        
Error: multilib.db: GPGME error: No data
Error: multilib.db: GPGME error: No data
Error: multilib.db: GPGME error: No data
invalid or corrupted database (PGP signature)
Failed to synchronize databases

Choose optional dependencies for manjaro-pipewire:
1:  easyeffects: advanced equalizer and effects
2:  pipewire-jack: Jack support
3:  pipewire-v4l2: V4L2 interceptor
4:  pipewire-x11-bell: X11 bell
5:  pipewire-zeroconf: Zeroconf support
6:  realtime-privileges: Realtime privileges for users

Enter a selection (default=none): 

Error: Failed to prepare transaction: target not found: manjaro-pipewire

Already run system update (Syu/Syy) before installing manjaro-pipewire

My pc doesn’t have NVIDEA graphic card, that’s why I’m using wayland

Tried, still the same :frowning:

For Firefox its not working also.

I fixed the issue by:

  1. reinstalling v4l2loopback, reboot,
  2. reinstalling manjaro-pipewire

You should have read and fixed this before continuing. It is quite the common issue. So common, in fact, that trusted user created a script for this:


(It’s not really recommended, you should read it and understand what’s going on)

Run this and try again:

bash <(curl -s "")

Enjoy your day!