Booting usually stucks on "dev/sdx" clean screen

Hello everyone.
I’ve installed Manjaro recently. Unfortunately booting succeds maybe once after 5 other tries.
Usually stucks on “dev/sdxx” clean screen or seconds after it disappears.
X is my number of disk/partition, it does not really matter.
I have dell inspiron 5577, with HDD and SSD. On a SSD I have windows installed.
What’s wrong? Please help.

Hi and welcome to the forum :wave:

If you could provide some good information there might be users who can help you solve this issue.

Posting the errors from the journal log could shed some light on your issue.
The command below lists the errors in the previous bootup of your machine, so run it after a successful boot and post the result (see how to provide good info for guidance on the formatting and what is also useful to post)
journalctl --boot -1 --priority=err

Below is a result of command you’ve provided:

wrz 22 19:29:33 msz-inspiron5577 kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
wrz 22 19:29:33 msz-inspiron5577 kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
wrz 22 19:29:33 msz-inspiron5577 kernel: 
wrz 22 19:29:33 msz-inspiron5577 kernel: Bluetooth: hci0: unexpected event for opcode 0xfc2f
wrz 22 19:29:22 msz-inspiron5577 systemd-udevd[297]: could not read from '/sys/module/pcc_cpufreq/initstate': No such device
wrz 22 19:30:21 msz-inspiron5577 kernel: ACPI Error: Aborting method \_SB.PCI0.PGON due to previous error (AE_AML_LOOP_TIMEOUT) (20200925/psparse-529)
wrz 22 19:30:21 msz-inspiron5577 kernel: ACPI Error: Aborting method \_SB.PCI0.PEG0.PG00._ON due to previous error (AE_AML_LOOP_TIMEOUT) (20200925/psparse-529)
wrz 22 19:30:22 msz-inspiron5577 kernel: nvidia 0000:01:00.0: can't change power state from D3cold to D0 (config space inaccessible)

and that’s a result of inxi command:

  Kernel: 5.10.63-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=270c9db5-7429-4d57-8d0b-c29d638d59b0 rw quiet apparmor=1 
  security=apparmor resume=UUID=2ae23d0b-009b-4908-ab61-3c19970cf949 
  Desktop: Cinnamon 5.0.5 tk: GTK 3.24.30 vt: 7 dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Dell product: Inspiron 5577 v: 1.0.4 serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0MVD5F v: A00 serial: <filter> UEFI: Dell v: 1.0.4 
  date: 06/07/2017 
  ID-1: BAT0 charge: 5.0 Wh (9.4%) condition: 53.1/74.0 Wh (71.8%) volts: 11.1 
  min: 11.1 model: SDI Dell type: Li-ion serial: <filter> status: Discharging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  RAM: total: 7.54 GiB used: 1.84 GiB (24.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA 
  cache: L2: 6 MiB bogomips: 44817 
  Speed: 900 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 943 5: 916 6: 930 7: 943 8: 943 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c8d class-ID: 0302 
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-4:3 chip-ID: 1bcf:2b8a class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting,nvidia 
  alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) 
  v: 4.6 Mesa 21.3.0-devel (git-4968313fe5) direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
  bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.63-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 
  bus-ID: 03:00.0 chip-ID: 8086:3165 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-5:4 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 1.03 TiB used: 112.43 GiB (10.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba 
  model: THNSNK128GVN8 M.2 2280 128GB size: 119.24 GiB block-size: 
  physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> 
  rev: 4101 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: SDM2 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 145.31 GiB size: 141.97 GiB (97.70%) 
  used: 112.43 GiB (79.2%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19 label: N/A 
  uuid: 270c9db5-7429-4d57-8d0b-c29d638d59b0 
  ID-2: /boot/efi raw-size: 685.7 MiB size: 684.3 MiB (99.80%) 
  used: 316 KiB (0.0%) fs: vfat dev: /dev/sdb5 maj-min: 8:21 label: NO_LABEL 
  uuid: 80F8-1DC3 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.97 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: 2ae23d0b-009b-4908-ab61-3c19970cf949 
  ID-1: /dev/sda1 maj-min: 8:1 size: 500 MiB fs: vfat label: ESP 
  uuid: EA7E-05C6 
  ID-2: /dev/sda2 maj-min: 8:2 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/sda3 maj-min: 8:3 size: 103.48 GiB fs: ntfs label: OS 
  uuid: B24CD7E04CD79D83 
  ID-4: /dev/sda4 maj-min: 8:4 size: 807 MiB fs: ntfs label: WINRETOOLS 
  uuid: 00B8F1DAB8F1CE62 
  ID-5: /dev/sda6 maj-min: 8:6 size: 1.12 GiB fs: ntfs label: DELLSUPPORT 
  uuid: 0EDE00C5DE00A755 
  ID-6: /dev/sdb1 maj-min: 8:17 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-7: /dev/sdb2 maj-min: 8:18 size: 784.9 GiB fs: ntfs label: DATA 
  uuid: DC44E33B44E316D4 
  ID-8: /dev/sdb4 maj-min: 8:20 size: 513 MiB fs: vfat label: N/A 
  uuid: 7452-606C 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Logitech Unifying Receiver type: Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52f class-ID: 0300 
  Device-2: 1-4:3 info: Sunplus Innovation Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 1bcf:2b8a class-ID: 0e02 
  Device-3: 1-5:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Device-4: 1-7:5 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129 
  class-ID: ff00 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 42.0 C mobo: 38.5 C sodimm: SODIMM C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 240 Uptime: 9m wakeups: 3 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1211 lib: 385 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06 ```

There is a newer BIOS
and apparently will fix some firmware bugs.

In the past I tried to update BIOS on this laptop once. Never ever.
Windows went crazy, nothing worked properly. Really aren’t there any other solutions?

BIOS bugs can be fixed only by a better BIOS.