Booting to white error screen (please Contact System administrator)

booting to white error screen oh no something has gone wrong a problem has occurred and the system can t recover please Contact System administrator

Switch to TTY with Ctrl + Alt + F5 for example and run this commands one by one:

sudo pacman-mirrors -f && sudo pacman -Syyu
rm -r ~/.config/dconf
rm -r ~/.local/share/gnome-shell
systemctl reboot
1 Like

Just tried this, after updating to latest testing and seeing this error. Unfortunately doesn’t seem to help in my case.

Make sure there was no partial update:
sudo pacman-mirrors -f && sudo pacman -Syyu
Make sure your GPU drivers are ok, try a different kernel too.
Disable the extensions and then enable them one by one to see if there is one that makes GDM fail.

I did run sudo pacman-mirrors -f && sudo pacman -Syyu as you suggested in your initial post.
I tried the 5.8 kernel, but I guess I could try an older one too.

How would I best check the GPU drivers?

It seems like a systemd-coredump is happening.

See if this might help

Usually the inxi -Fazy from terminal or TTY gives the complete information about the system to start investigating.

Disabling all extensions doesn’t seem to help.

Also tried the 5.7 kernel, but didn’t help.

inxi doesn’t show anything suspicious, I would upload it, but I’m not sure how to easily do that from tty.

The white Oh no error is generated by gnome-shell. The typical troubleshooting procedure is

  1. login to console
  2. disable all gnome extensions from cli
  3. systemctl restart gdm
  4. log into your desktop and start enabling extensions one by one to see which one is the culprit

In addition to extensions, gnome shell themes can cause breakage like this, so you may want to revert to defaults if you have something custom going on.

These commands revert all gnome settings to their defaults, so you can also try that as a nuclear option.

I already nuked those folders :slight_smile:
But didn’t fix it :confused:

I think I’m seeing this gnome-shell crashes when a cursor is not found (#355) · Issues · GNOME / mutter · GitLab

So I did run gsettings set org.gnome.desktop.interface cursor-theme 'Adwaita'

Running x or wayland from the tty works after that, but I still get the error screen on boot.

Here’s the inxi output:

  Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=5d22ff53-87eb-4a34-b2c9-ea68e6d0729f rw quiet 
  Console: tty 5 DM: GDM 3.38.1 Distro: Manjaro Linux 
  Type: Convertible System: Acer product: Spin SP515-51GN v: V1.14 
  serial: <filter> 
  Mobo: KBL model: Buzz_KL v: V1.14 serial: <filter> UEFI: Insyde v: 1.14 
  date: 01/09/2019 
  ID-1: BAT0 charge: 37.1 Wh condition: 42.9/50.8 Wh (84%) volts: 16.1/15.3 
  model: SMP-SDI3320 AC14B7K type: Li-ion serial: <filter> status: Discharging 
  Device-1: hid-0003:04F3:25A1.0003-battery model: ELAN Touchscreen 
  serial: N/A charge: N/A status: N/A 
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 880 2: 834 3: 844 
  4: 841 5: 842 6: 891 7: 843 8: 843 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] 
  vendor: Acer Incorporated ALI driver: nvidia v: 450.80.02 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8d 
  Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 1-7:4 
  chip ID: 04f2:b5f7 
  Display: server: 1.20.9 driver: modesetting,nvidia unloaded: nouveau 
  alternate: fbdev,intel,nv,vesa tty: 240x67 
  Message: Advanced graphics data unavailable in console. Try -G --display 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 168c:003e 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 1.38 TiB used: 159.24 GiB (11.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: GPT 
  ID-2: /dev/sdb vendor: Micron model: 1100 MTFDDAV512TBN size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: A020 scheme: GPT 
  ID-1: / raw size: 194.63 GiB size: 191.07 GiB (98.17%) 
  used: 159.17 GiB (83.3%) fs: ext4 dev: /dev/sdb5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 37.0 C mobo: 30.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 209 Uptime: 5m Memory: 7.69 GiB used: 475.3 MiB (6.0%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1822 
  pacman: 1819 lib: 467 pkg: 0 flatpak: 3 Shell: fish v: 3.1.2 
  running in: tty 5 inxi: 3.1.05

I’ve got the same problem after last update. After trying few things you guys discused here, I have find a solution, I think. The problem is with the cursor.

To fix it, go in TTY and instal this:

pacman -S xcursos-breeze

then the problem was fixed for me. Hopefully it will work for you too.


Thank you, that fixed it for me too.
But it’s xcursor-breeze not xcursos-breeze. It seemed to have downgraded it from 5.18.x to 5.11.5-1 for me, after that was done, I could restart and login as normal.

Hi there,
I don’t mean to flog a dead horse but this page in my search bulb is the number one search result for ‘manjaro oh no something has gone wrong’ )) , so let me jump in here and just document my experience for myself, albeit with hope it may save someone’s day some time.
So, in my case the clue in logs was pretty obvious

Could not find cursor. Perhaps set XCURSOR_PATH?

Nonetheless, no matter what I’ve tried about ‘gsettings set org.gnome.desktop.interface cursor-theme’ and ‘XCURSOR_PATH’ it didn’t work.

Long story short, the solution finally came (what a surprise!) from the ArchWiki, GDM#DConf_configuration page

For the latter approach, you can log into the GDM user with the command below:
# machinectl shell gdm@ /bin/bash

and then just another shot for what I’d already done couple dozens times by that point

gsettings set org.gnome.desktop.interface cursor-theme 'Breeze'

and voilà!, it did the trick.
(the faulty value was ‘xcursor-breeze’, I guess this one has been installed at some point manually by mistake and hence vanished then).

P.S. Never paid any close attention to systemd-machined component. What an incredible learning opportunity! :smiley:

1 Like