Booting stuck indefinitely on Plymouth loading screen

What the title says.

The issue here specifically is that I’m wondering whether or not reinstalling Manjaro could brick the drive, given I’ve encrypted it when I installed it. I’m also still wondering if there is a possibility that me not installing with secure boot disabled was the actual root issue or not and if there’s actually an easier or more direct fix for this.

This is on a dual-boot system (or was supposed to be until I couldn’t boot into Manjaro completely) with Windows 10 running on a separate drive. Had windows installed with one SSD drive and then put the next one in and installed Manjaro on that without secure boot properly disabled and I have not been able to completely boot into Manjaro since after the first bootup (I’m assuming I’m successfully booting past grub after but not a full boot as it gets stuck on the loading dot screen indefinitely)

I’ve actually posted help on this subject before but didn’t get much of any helpful responses, probably due to the fact that I wasn’t posting system info so I’ll just post it here:

AMD Ryzen 5800x 8-Core Processor
AMD Radeon RX 6800 16 GB
DDR4 16x2 dual channel configuration

I don’t remember what the max clock frequency is for the RAM, but it might be 3200; I’m assuming the current max is 2400 at the moment because I haven’t messed with any overclock settings.

If you can reach GRUB then it’s not a secure boot issue. This appears to be an XY problem, you should be asking for help with your boot problems. Though, if a reinstall fixes it, then all’s well that ends well.

To answer your initial question: the encryption created when you install Manjaro does not apply to the entire drive, but only to the partitions that contain Manjaro. Deleting the partitions in order to reinstall won’t brick your drive, but it will permanently corrupt the original contents of those partitions. (You won’t be able to recover the data, even with heavy duty data recovery tools.)

Okay, well if it’s not the secure boot that’s the issue here, how exactly would I go about fixing this issue? I have no idea where to start myself.

As a sidenote: The only thing I have tried that could’ve addressed the issue is turning off secure boot after many tries to boot into Manjaro because I didn’t realize I needed to clear secure boot keys prior in addition to switching the os setting to “Other OS”. That did not fix it, however.

We start by finding details on the issue. For starters, please boot the live environment (USB) and paste your system details to the thread.

Next, when you get to GRUB before booting Manjaro, press “e” on your keyboard. Find the line that starts with linux, and delete the arguments quiet and splash if present. Press Ctrl + X to boot, and you should get a bunch of logs. If anything sticks out to you, write it down. If not, phone pictures aren’t ideal, but such is. Make sure all the text is clear.

It is late here so I’m going to go to bed, someone else will probably come in to help. If not, I will try to do some more in the morning.

use profile settings , one for windows ( secureboot) , other one for Linux
( see in save profile settings )
if you can boot with USB live manjaro ,
open a terminal and a browser on this topic
and report

inxi -Fza
sudo parted -l 

I just now tried booting through the flash drive image and for some reason or another I now realize that the flash drive itself is and has been partitioned and encrypted just like the NVME SSD. I’ll have to address this tomorrow as it is very late for myself and have places to go in the morning. Will post a report when I get back and rewrite another image onto the flash drive.