Bootable usb program that actually works?

I’ve tried two of the bootable usb programs in the repo, and neither one of them works. One just opens a small password window and then closes, and the other opens but never actually loads the .iso file even when you select it. So I’d really like to use one of the more well known, mainstream options such as Yumi or Rufus. But they’re not in the repos. Can anyone suggest a good bootable usb creator that actually works?

SUSE Studio Image Writer. It’s in the repo under the name imagewriter. :arrow_down:

5 Likes

have you tried etcher?

1 Like

As Aragorn I recommend Suse Image Writer, on a side note, can you tell us which programs do not work? this is very unlikely.

1 Like

You can also try Ventoy.

3 Likes

@photonfanatic
its in the repo too…
flashing it on the usb and then you can just opy paste the downloaded iso into the stick !

I think your primary issue is impatience - never pull the stick without flushing cache - as doing so will most certainly ruin the content.

The terminal dd command has been proven over the years - only windows ISO do not work - for those you need woeusb (AUR).

For apps not yet mentioned popsickle and mintstick comes to mind - both in the Manjaro Repo.

4 Likes

I’m an Etcher Fan My Self

1 Like

I recommend Ventoy like @Keruskerfuerst, it is the best program I have used so far.

Or Ventoy, this runs W10 as well.

That’s a reply that I usually get, but it doesn’t make the errors go away lol. I’ve tried every program suggested here except etcher. I will try that one next. They all have some reason or another that they just can’t work. For example, try to install Yumi from the arch repo. Tell me if it works. This is just a little experiment I’d like to run. I couldn’t get it to work, but then again maybe it’s just a version that is too old to work.

I’m also not taking the flash drive out before it’s finished. This is because thus far, I haven’t been able to get any of them to actually start the process. I got tired of fighting with it and just loaded up Rufus on windows 10 and it works great.

This is my overall experience with software from the repos. It’s hit and miss. If it’s a big popular program, it’ll work. If it’s small and maybe somewhat obscure, good luck. I use Pamac and I’m not doing anything special, I just install it and then launch it from the start menu. Many of them will open, but throw some error or another when you go to execute their main function. Some of them never make it that far, just crashing immediately.

If you don’t find a suitable GUI package working for you then maybe the CLI approach using the dd command as mentioned by @linux-aarhus could be a solution:

3 Likes

This package is a pre-compiled binary, from 2015, so no thanks, also:

jonathon commented on 2018-03-19 08:59

Given the upstream page still suggests running the Windows version of YUMI 2.0.5.4 under WINE is it time for a deletion request? Or is making this package use WINE an option?

I just used Suse Image Writer recently and it worked so I don’t know, maybe try to start from terminal and see the errors it throws? If you tested everything people suggested I guess issue is on your end so maybe try to find some errors on your side?

Have you tried,

Easy2Boot

Howdy!

Install gnome-disks ( sudo pacman -S gnome-disk-utility ), launch it, select your USB, then click the menu button on the top right corner to finally select “restore disk image”.
-> Select the .iso and hit restore!

Have a wonderful day!

dd has never failed me…

2 Likes

dd

oh darn … @tuxmanjarino beat me to it. :laughing:

Actually aarhus beat you both lol

Too big of a newb, don’t know how to use that. Although I’ll look it up and see if I can make it work. Thanks to all for the replies!

maybe look at that ^