Bootable usb program that actually works?

Ended up just doing it on windows, where everything worked fine. Back to that whole “just works” thing.

No, rather back to "I know how this works and I don’t have the patience to learn that."

Just for the sake of comparison, if you were to put me at the keyboard of a Windows PC, I wouldn’t know how to do squat, because I don’t use Windows, and I find it an illogical operating system. In GNU/Linux, everything makes sense, and it does what I tell it to do, not what it might think I mean.

You put Manjaro on your computer. That means that you were looking for something other than what Windows has to offer, and if that is the case, then you also owe it to yourself to take out the time to understand and learn how to properly use GNU/Linux. Otherwise there’s no point.

Nobody’s going to demand that you’d become a skilled IT specialist, but there’s a certain responsibility involved nevertheless. 99% of the problems we’re seeing here at the forum are from Windows users who are expecting GNU/Linux to be exactly the same thing as Microsoft Windows but with a different name and a different look. Well, not so ─ it’s an entirely different operating system design, and for that matter, a very logical, well-documented and transparent one.


I was going to comment on this, but you said it all.


Well that’s fine, but they did set up a “software center” in the form of pamac. Your typical app store layout found across multiple operating systems, not just this one. Those do generally all work the same. You open it, you type in or select the software you want to download/install, and you click on it or otherwise tell it to go. It goes. Now it’s on your computer, and you tell it to open, just like you tell every other piece of software to open. And most of them do. It’s a great thing.

Only this particular one (or ones) don’t. That means they’re failing to fulfill their function as intended. That’s not my fault, it’s not because I’m a new linux user, or that I’m more familiar with windows. It wouldn’t have worked for someone who had never used windows, or any other OS. It wouldn’t have worked for someone who is experiencing manjaro as their very first operating system.

There isn’t some extra thing I’m supposed to be doing here. The suse image writer software even opened up. It was trying to work as intended. It didn’t. If you were to sit in front of this computer, you’d have the exact same experience. That said, I’m not saying that there’s not something wrong with my computer/install. Other people seem to have the programs open up and work fine. Mine stalls out on 5%. I do not know why. I really shouldn’t have to know why, not when it was laid out the way it is. For a 3 click installation and then you’re up and running. Again I’m not somehow blaming anyone for my computer problems, I’m just trying to figure out why. I have the same problem with VLC and Kodi. Kodi simply never opens (even on a brand new, fresh install of Manjaro) and VLC will just crash half the time. I switched to SM Player, and now all these problems are gone. So I’ll just use SM Player instead.

I know not everyone thinks this about new users like me, but these types of replies always remind me of something - In the video game industry, some gamers will have crashes or slowdowns that say… 60% of the other gamers just aren’t experiencing. Then others just won’t understand how this can be happening. After all, it’s not happening to them, so they must be making it up, right? I can read through this forum, and find 100 other problems that I’m just not having. Things that I’m using/doing, that other people are having some form of problem with. But not me. These are just the problems I am having.

You refuse to do what we suggest to help you troubleshoot, so it’s on you at this point, no matter how you try to twist the story.

The issue is definitely on your side, all these programs suggested perfectly work for everyone but you.


Then explain why Kodi won’t start on a brand new install? Right out of the gate, it won’t start. So no, you’re wrong. There’s no twisting that.

Granted, that’s linux mint. Goes to show you other people have had the exact same problem I’m having, in the past. You need to learn that not everyone has the same rosy experience that you have. I’ve also said before that as I’m very new, I don’t generally understand command line help. I have to just sort of figure it out as I go, which takes time and google.

I’m not magician so I can’t tell why people have trouble on Linux Mint with KODI.

starting a program from terminal is a simple as:

  • open a terminal
  • type the program name
  • press Enter key

Two things you have to keep in mind… :arrow_down:

  1. Writing to a USB stick can be a very slow process that appears ─ emphasis ─ to stall at certain points because the data can’t be transferred as fast to the device as the computer can read it from its internal storage, or when the computer is low on RAM.

  2. USB sticks do wear out. They use flash memory, but they don’t have any wear-leveling logic built into them. Many USB sticks are therefore advertised at a larger capacity than what they really offer, exactly because they don’t support TRIM and because they don’t have any wear-leveling logic built in. I know, it’s dishonest, but that’s commerce for ya.

My advice would therefore be to first try with a different USB stick, and to give the writing process enough time to complete.


Capture d’écran vidéo de 2020-10-13 20_08_28

Yeah, I agree this is a super complicated process :face_with_hand_over_mouth:

1 Like


No idea what you’re talking about :face_with_hand_over_mouth:

:face_with_hand_over_mouth: There doesn’t appear to be anything called “Disque 16 Go” in the repos. :face_with_hand_over_mouth:

Doesn’t really matter though, I’ve already solved the problem.

Usually when people find a solution to an issue, after others tried to help, the respectful thing to do is to provide the solution so that everyone can benefit, and so the thread is not a useless piece of nothing in the end.

Kinda rude to end the thread with ‘I fixed it’.


So is sarcastically implying that something is super simple when someone is making it clear that it’s just not working. Which was why my reply sounded that way. Well at the risk of sounding like I’m complaining more, I’ll just say that I’ve come to expect this next part. It’s pretty much been my experience throughout. I’m cool with it, because everything has it’s advantages and disadvantages. It really doesn’t bother me, I’m just glad I finally solved it. Anyway:

It was all down to not having flatpaks enabled. Again I’m almost a complete newb to linux distros, I didn’t know anything about that. The usb problem (and Kodi too) was resolved when I enabled flatpaks. I thought that all I really needed to do to gain access to all kinds of extra software, was to enable the AUR. So I did. The standard Kodi doesn’t work. The flatpak does. The standard bootable usb creator doesn’t work. The flatpak does. Starts right up, no problem. Who knows what the difference is. In terms of Kodi, it’s about a 200Mb difference. Odd. Oh well.

Here’s another thing I find to be quite odd. On that new manjaro install on an HTPC… there’s no way to enable Snaps in Pamac. Only flatpaks. In my older manjaro install on my main linux rig, there’s no flatpak. Only snaps. And it’s not just a mislabeled setting either. They’re both really only searching for things that are a “snap” or a “flatpak”.

That tells me that all of these arguments have been pointless cause we were arguing over information that neither of us had. I didn’t know any better, and you all probably thought that I knew about flatpaks and snaps. It’s really no wonder that nothing suggested was of any help.

There is if you install pamac-snap-plugin which is an optional dependency of pamac-common. For Flatpak support, there’s pamac-flatpak-plugin.

Nope, sure didn’t. Folks were recommending solid, working software from the repos.


Yeah I don’t know what is going on, but it’s a no start on both my manjaro rigs. The snaps and flatpaks work though. I did note that the Kodi flatpak is 200 more megabytes than the solid software from the repo that doesn’t work for me. So who knows lol. Done trying to figure it out, it doesn’t work unless you use this other thing. Fine, I’ll use the other thing. Long as it’s Foss that’s all I really care about.

Just curious… which version did you install @photonfanatic ?


Tested now imagewriter and kodi… both work perfectly. I normally i don’t use them. And believe me it was just the pamac-manager nothing more. Both applications run like it should without a terminal. But i use XFCE and not KDE.

You have to choose the kodi-x11 version.

It is a mystery for me… that it didn’t work for you.

As suggested he could have started one of the non working application from terminal to try to gather some errors or other relevant output, but I don’t think he’s willing to do it so… Yes all these application work for anyone installing Manjaro. What we don’t know is what is different on his system, because something is modified/customized/broken, but that’s a whole new topic.

1 Like

No more waste of time.