Boot stuck seeing "disabling IRQ #0"

I installed Manjar 23 on my macbook air 2013, and after installed some device driver from the Software repository and changed some power saving configuration, I suffered a problem after reboot which is stucking at “disabling IRQ #0”. and keyboard didn’t works, only pressing power button make the laptop reboot.

and I found some reference from [Solved] MacBook Air 2013 “nobody cared …”, “Disabling IRQ #0” / Kernel & Hardware / Arch Linux Forums, and Boot stuck at Disabling IRQ - Support - Manjaro Linux Forum, I tried suggestions from that link, and tried “irqpoll” option in boot options as well, but didn’t works still.

The last lines in you first photo,
the message you are referring to in the title of this thread,
is just informative - it is not an error,
it is not the cause of your problem.

Perhaps undo what you did - return to the defaults?
you could try to do what that message suggests? :wink:

It did work - and after you changed something it didn’t anymore?
It’s not entirely clear from you post.

I have zero experience with Apple Hardware - often some special boot parameters seem to be needed.

I agree with Nachlese, you changed something that broke the system, change it back.

Are you 100% sure your keyboard was not working though? a REISUO does not work? [HowTo] reboot / turn off your frozen computer: REISUB/REISUO

I see a plymoth hook in there. Have you tried disabling that in /etc/mkinitcpio.conf and recompiling your kernels with sudo mkinitcpio -P.
Remove it from /etc/default/grub and run sudo update-grub

But I still recommend reverting back to a functioning config.