Boot Stuck at RootLinux: Clean..File..block


This is my first time posting here.

I am facing a problem with bootup. I had casually shutdown my laptop yesterday, and couldn’t start it again this morning.

The screen it is stuck at is:

RootLinux: clean, 235621/12812312 files, 1293123/123123 blocks
[FAILED] Failed to start pkgfile database update

I forced restarted and it now got stuck at only the first line.

Upon looking for various answers I learned a few things:

  • Ctrl+Alt+F2 opens up a terminal. (NEWBIE, pardon me :D)

  • Restarted after updating PACMAN sudo pacman -Syu. DIdn’t help

  • Then I ran a command kstart5 plasmashell, which showed an error

    qt.qpa.xcb: couldnot connect to display
    qt.qpa.plugins: couldn’t load the Qt platform plugin “xcb” in “” even though it was found.
    • There were some more lines…regarding reinstalling may fix it etc etc.
  • Then as suggested in the forum post somewhere, I reinstalled xorg-servers and all its dependencies.

    • Didn’t fix anything.
  • Reinstalled libxcb as mentioned in the forum. – didn’t fix anything.

If someone can help out on this, would be really grateful. I don’t really want to reinstall linux and potentially learn something while fixing this issue :slight_smile:

Tried xrandr and throws error = Cant open display

Do you have xcb package

What all you did before shutdown

yes, I have Xcb package if you mean libxcb

I was normally using the laptop. From what I can remember, I only installed virtscreen to link my laptop with ipad screen. it didnt work as it couldnt find second virtual screen.

Now it seems to me that manjaro isnt able to locate my screen/display.

Try removing virtscreen

already did

plz post result of xrandr --listmonitors
got from here

Also see these @dummifiedme