Boot partition in second drive

I’ve installed Manjaro Mate on a new SSD. A second drive has Kubuntu.
Both distros are listed in UEFI.

I need a bit of reassurance that the partitions are correct, especially the second drive one here which has ! and a — boot flag.

I guess I need the fat32 partition in this so that it shows in UEFI. Otherwise, is the fat32 partition needed in the second drive.

Sorry, but the forum would not let me post media files or even hyperlinks.

Thanks for having me on board.
John

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. The output to sudo parted --list would help then too.

:+1:

1 Like

This is the inxi output:

[howard@Szamitogep ~]$ inxi --admin --verbosity=7 --filter --no-host --width
System:
  Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=05eae7d8-64f2-4f83-a1ea-16f95a7e8380 rw quiet apparmor=1 
  security=apparmor resume=UUID=2c5f5a87-81b9-489d-9158-4712a322ca07 
  udev.log_priority=3 
  Desktop: MATE 1.24.1 info: mate-panel wm: marco 1.24.1 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: Z170-E v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 3801 date: 03/14/2018 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Solar Keyboard K750 
  serial: <filter> charge: 85% rechargeable: yes status: Charging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M325 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
Memory:
  RAM: total: 15.58 GiB used: 1.53 GiB (9.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: E2 
  L2 cache: 6 MiB bogomips: 28009 
  Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:
  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: PC Partner Limited driver: amdgpu v: kernel bus ID: 01:00.0 
  chip ID: 1002:67ef class ID: 0300 
  Display: x11 server: X.org 1.20.10 compositor: marco v: 1.24.1 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.40.0 
  5.10.15-1-MANJARO LLVM 11.0.1) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  class ID: 0403 
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aae0 class ID: 0403 
  Device-3: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK Xonar DSX 
  driver: snd_virtuoso v: kernel bus ID: 06:00.0 chip ID: 13f6:8788 
  class ID: 0401 
  Sound Server: ALSA v: k5.10.15-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 class ID: 0200 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: TP-LINK TG-3468 driver: r8169 v: kernel port: d000 bus ID: 04:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp4s0 state: down mac: <filter> 
  WAN IP: <filter> 
Bluetooth:
  Message: No Bluetooth data was found. 
RAID:
  Message: No RAID data was found. 
Drives:
  Local Storage: total: 7.28 TiB used: 49.55 GiB (0.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD2003FZEX-00Z4SA0 size: 1.82 TiB block size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 
  scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 QVO 1TB 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 1B6Q scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital 
  model: WD4004FZWX-00GBGB0 size: 3.64 TiB block size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0A81 
  scheme: GPT 
  Message: No Optical or Floppy data was found. 
Partition:
  ID-1: / raw size: 488.54 GiB size: 479.87 GiB (98.23%) 
  used: 49.33 GiB (10.3%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19 label: N/A 
  uuid: 05eae7d8-64f2-4f83-a1ea-16f95a7e8380 
  ID-2: /boot/efi raw size: 600 MiB size: 598.8 MiB (99.80%) 
  used: 280 KiB (0.0%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: N/A 
  uuid: 80F7-C1FE 
  ID-3: /run/media/howard/MyWinStuff raw size: 1.55 TiB 
  size: 1.55 TiB (100.00%) used: 223.3 MiB (0.0%) fs: ntfs dev: /dev/sda1 
  maj-min: 8:1 label: MyWinStuff uuid: 635B2E3356F6C764 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 3.91 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb2 maj-min: 8:18 label: N/A 
  uuid: 2c5f5a87-81b9-489d-9158-4712a322ca07 
Unmounted:
  ID-1: /dev/sda2 maj-min: 8:2 size: 271.51 GiB fs: ext4 label: N/A 
  uuid: 62bf8816-3bb8-4ba2-908f-de4f7e4adf5d 
  ID-2: /dev/sdc1 maj-min: 8:33 size: 512 MiB fs: vfat label: N/A 
  uuid: 607D-E837 
  ID-3: /dev/sdc2 maj-min: 8:34 size: 931.01 GiB fs: ext4 label: N/A 
  uuid: b0f459db-1540-4214-aedc-78b985e72330 
  ID-4: /dev/sdd1 maj-min: 8:49 size: 48.83 GiB fs: ext4 label: N/A 
  uuid: 6bba14e3-8176-4a52-93c7-8a2a4201dcc8 
  ID-5: /dev/sdd2 maj-min: 8:50 size: 3.59 TiB fs: <superuser required> 
  label: N/A uuid: N/A 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 1-6:2 info: Canon PIXMA iX6850 Printer type: Printer driver: usblp 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 04a9:10e3 class ID: 0701 
  serial: <filter> 
  Device-2: 1-14:3 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c52b class ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
Sensors:
  System Temperatures: cpu: 22.0 C mobo: N/A gpu: amdgpu temp: 26.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 777 
Info:
  Processes: 202 Uptime: 3h 21m wakeups: 73 Init: systemd v: 247 Compilers: 
  gcc: N/A Packages: pacman: 1173 lib: 403 Shell: Bash v: 5.1.0 
  running in: mate-terminal inxi: 3.3.01 
[howard@Szamitogep ~]$ 

This is the sudo parted --list:

[howard@Szamitogep ~]$ sudo parted --list
[sudo] password for howard: 
Model: ATA WDC WD2003FZEX-0 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  1709GB  1709GB  primary  ntfs
 2      1709GB  2000GB  292GB   primary  ext4


Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name     Flags
 1      1049kB  630MB   629MB   fat32                    msftdata
 2      630MB   4824MB  4194MB  linux-swap(v1)           swap
 3      4824MB  529GB   525GB   ext4            Manjaro


Model: ATA WDC WD10EZEX-08M (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  538MB   537MB   primary  fat32        boot
 2      538MB   1000GB  1000GB  primary  ext4


Model: ATA WDC WD4004FZWX-0 (scsi)
Disk /dev/sdd: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  52.4GB  52.4GB  ext4
 2      52.4GB  4001GB  3948GB

What to do now?

1 Like

Well, nothing! It’s allowed to have multiple ESPs, (EFI System Partitions) and that’s what you have, so that’s no worries if you want to switch OSes using the UEFI firmware instead of grub and that’s what you did.

It’s not what I would have done, but it’s perfectly allowed.

(emphasis mine)

No, you don’t need that: That’s the advantage of UEFI: You can boot multiple OSes of the same ESP but some people don’t like that and want each OS to have their own ESP, and that’s what you have…

And that i is perfectly fine, but I have a triple boot system using 1 ESP:

sudo ls /boot/efi/EFI
Boot  Manjaro  Microsoft  OEM  rEFInd  Tools  Ubuntu

:man_shrugging:

1 Like

Aw, thanks! I’m glad to have the reassurance.

I notice you use rEFind. May I ask why?

1 Like

Because:

  • I’m a nerd
  • a tinkerer
  • a dork

And rEFInd comes with an EFI shell and that allows me to add / remove EFI drivers and follow this manual. (I’m on page 48 since the last 3 months)

:crazy_face: :stuck_out_tongue_winking_eye:

1 Like

:astonished:

The manual put me right off. Grub works.

1 Like

For me, I personally like rEFInd because it’s so much more simple than grub to me. For grub, you have to use update-grub, and make sure it plays well with all of your OS’s

I don’t have grub installed on my computer, only rEFInd. What it does is at boot, it searches for all bootable OS’s (for me is Windows 10, Manjaro, Arch Linux, OpenSUSE) and show it all on the screen.

i.e. (old screenshot)

https://archived.forum.manjaro.org/t/refind-sunset-theme/38078

2 Likes

I run Manjaro and Kubuntu only, so rEFind, though neat, would be overkill just now.

I ran into so much trouble with Windows 10 that I removed the darned thing. Thankfully, I had it on a separate HDD. Otherwise, it seems you cannot uninstall it, not completely.

Thanks for the heads up though!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.