Boot issues every update

Hi, new user here. I’ve been working with Manjaro for a month now and I’m happy with it, but almost every update I’m forced to change some configuration because of different boot issues.

The first time I had a black screen on login, which I solved reinstalling Nvidia drivers.

The second time I had black screen before grub, so I reinstalled grub.

The third time I had a black screen on login again, but this time reinstalling Nvidia drivers didn’t work and I ended changing the word quiet with nomodeset in the grub menu to solve this.

The fourth time I had a black screen after grub. I solved that pressing CTRL + ALT + F2 and entering this command sudo mhwd -a pci nonfree 0300

This fifth time I have a black screen after login but it actually boots to the desktop if I wait for a minute or so.

This is my inxi:

  Kernel: 5.15.59-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=b5fcaa67-ea50-4414-a172-5316104eeede rw quiet splash apparmor=1
    security=apparmor resume=UUID=d97a293e-b251-4183-8cf1-2d533d5ba9f3
  Desktop: GNOME v: 42.3.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM
    v: 42.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: Z87-HD3 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: Z87-HD3 v: x.x serial: <superuser required>
    BIOS: American Megatrends v: F2 date: 04/17/2013
  Device-1: sony_controller_battery_00:1b:fb:6a:70:41 model: N/A serial: N/A
    charge: N/A status: N/A
  RAM: total: 7.65 GiB used: 2.98 GiB (38.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell gen: core 4
    built: 2013-15 process: Intel 22nm family: 6 model-id: 0x3C (60) stepping: 3
    microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 3578 high: 3593 min/max: 800/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3552 2: 3577 3: 3593
    4: 3592 bogomips: 25549
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Gigabyte driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm
    built: 2010 ports: active: none empty: HDMI-A-1,HDMI-A-2,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0300
  Device-2: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: ZOTAC
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-07) arch: Turing code: TUxxx
    process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:2187
    class-ID: 0300
  Display: x11 server: v: with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: nouveau alternate: fbdev,nv,vesa gpu: i915,nvidia display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1650 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    driver: snd_hda_intel v: kernel bus-ID: 3-9:4 chip-ID: 1b3f:2008
    class-ID: 0300
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-3: NVIDIA TU116 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Device-4: Generalplus USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.59-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.21 running: no
  Sound Server-4: PulseAudio v: 16.1 running: yes
  Sound Server-5: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter
    driver: rtl8192ee v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c000
    bus-ID: 06:00.0 chip-ID: 10ec:818b class-ID: 0280
  IF: wlp6s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.36 TiB used: 28.57 GiB (2.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: TR200 size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 15.2 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 QVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WDS250G2B0A-00SM50 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
    scheme: MBR
  Optical-1: /dev/sr0 vendor: ATAPI model: iHAS124 E rev: 4L03
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 214.77 GiB size: 210.34 GiB (97.94%) used: 28.57 GiB
    (13.6%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: b5fcaa67-ea50-4414-a172-5316104eeede
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: d97a293e-b251-4183-8cf1-2d533d5ba9f3
  ID-1: /dev/sdb1 maj-min: 8:17 size: 465.76 GiB fs: ext4 label: LinDATUAK
    uuid: 4fec9586-6137-449b-a0a9-8bd44b83e499
  ID-2: /dev/sdb2 maj-min: 8:18 size: 465.75 GiB fs: ntfs label: WinDATUAK
    uuid: 3F81D0DB3FD3261C
  ID-3: /dev/sdc1 maj-min: 8:33 size: 579 MiB fs: ntfs label: Reservado para
    el sistema uuid: 720A77040A76C49F
  ID-4: /dev/sdc2 maj-min: 8:34 size: 232.32 GiB fs: ntfs label: N/A
    uuid: 14847CA2847C87CE
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Logitech Keyboard K120 type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 90mA chip-ID: 046d:c31c class-ID: 0300
  Device-2: 3-4:3 info: Sony Batoh Device / PlayStation 3 Controller
    type: HID driver: sony,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 500mA chip-ID: 054c:0268 class-ID: 0300
  Device-3: 3-9:4 info: Generalplus USB Audio Device type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 1b3f:2008 class-ID: 0300
  Device-4: 3-10:5 info: TiPro Wired Gaming Mouse type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 480mA chip-ID: 1222:2018 class-ID: 0301
  Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: nvidia temp: 40 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 35%
  Processes: 225 Uptime: 53m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 alt: 11
  clang: 14.0.6 Packages: pacman: 1389 lib: 365 flatpak: 0 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.20

I guess my issue is something with the video drivers when mayor updates happen, but I’m at a loss because every time the solution to the problem is different even if related. How should I proceed from now on? Thanks in advance.


A couple of things to consider:

is the BIOS version since when the motherboard was released and there are updates that you should consider GA-Z87-HD3 (rev. 1.x) Support | Motherboard - GIGABYTE Global
But make sure you update the right BIOS for your motherboard version.

From your description is seems like each time there was something during the update that somehow leads me to conclude at corrupted packages. Download is slow?
I also see that you still have the iGPU connected but not used so is better to disable it from BIOS.
For Gnome, when comes to Nvidia GPU and drivers i noticed that enabling early KMS makes things better.
See here:

1 Like

Hi @Joanna_Dark, and welcome!

To analyze that, start by inspecting, and providing the output for:



systemd-analyze blame

How did you do the updates?

Have a look here:

Also, before applying any updates, read thorough the #announcements:stable-updates, the second post in the thread is usually a list of gotchas and fixes.

Once again, do not apply updates blindly!

Use the matray app to keep informed of updates. Or the RSS feed.

1 Like

Hello! Thanks for your answer.

I updated the BIOS to the newest version I found, then disabled iGPU and applied this early KMS. Even if it didn’t solve my issue, I’m grateful for this tips. I have some doubts regarding early KMS and what it does exactly. I understand this makes so the graphic drivers have priority loading over any other “command” that tries to control the display?

Anyway I found the solution being in the grub.cfg again. Apparently quiet mode was set again, due to an upgrade or maybe myself trying to fix something. This is what I did to solve the issue:

went to:


modified this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=1 security=apparmor resume=UUID=d97a293e-b251-4183-8cf1-2d533d5ba9f3 udev.log_priority=3"

to this:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset splash apparmor=1 security=apparmor resume=UUID=d97a293e-b251-4183-8cf1-2d533d5ba9f3 udev.log_priority=3"

ended generating a new grub.cfg with this new template:

grub-mkconfig -o /boot/grub/grub.cfg

I tried rebooting several times and now it works fine (Except one time mouse buttons didn’t work but I’m ignoring that one for now sigh)


I tried that command more than once with similar values to this:

Startup finished in 1.982s (kernel) + 7.200s (userspace) = 9.182s reached after 7.199s in userspace.

So I understand there wasn’t any process giving issues or waiting more than it should.

I’m one of those that upgrades blindly every single time so I’ll be careful from now on. There is one thing I don’t understand from the text you linked however: Why is better to update from TTY instead of from GUI? It’s because GUI uses some packages that need to be restarted on update?

I cannot say what your issue is -but suffice to say - it ia a matter of configuraton for your specific system.

I have used a variety of systems over the years - never had issues with Manjaro.

1 Like

There’s an archwiki page about almost anything: Kernel mode setting - ArchWiki

I’m guessing something like that, yeah. Although, I’m actually a bit naughty. I don’t do it in a TTY. I just do it in a terminal emulator. But I do merge all .pacnew files and so on before rebooting. So far, so good.

scheme: MBR

Maybe I’m missing something but it seems that manjaro is installed in legacy bios mode on sda1. If that Is/was intended (and the board can handle uefi) then bios settings should be set accordingly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.