Boot fails after full storage problem

I can’t boot Manjaro anymore, after I choose it from the Grub menu, I only get this:

“Disabling IRQ #31”, and the mouse pointer (can move it).
This is the screen I also got at my last attempt of shutting down the system.
I found that my system storage was full (got several messages during updating and app usage). So I deleted a lot of files and freed up a good 50 GB of space, but when I shut down, this happened. I had to force power off, and now I get the same experience at boot…

When it gets stuck, can change tty? For exmaple, does it open a terminal with CTRL+ALT+F2? If so, get the output of journalctl -p3 -band post it here.

Yes, I forgot to mention that - tty works!

Do you have a ZFS filesystem? Please post the output the output of lsblk -f. I’m guessing the problem lies in the last line (the login error). Please post the output of systemctl status gkr-pam

It can also help to get more info about your system: inxi -Fayz

No it’s ext4. Looks like there is no gkr-pam (whatever that is).

a LOT of stuff comes up doing an internet search for systemctl gkr-pam, but it’s mostly gibberish to me, it seems to be a very pervasive issue.

Please post the output of systemctl status sddm

What happens if you change back to tty1 from tty2? If tty1 presents you a bash login, try tty7.


If I switch from tty2 back to tty1, it’s always the old situation depicted in first post, that message and the mouse pointer.
tty7 only has a blinking text cursor.

Please post the output of journalctl -b | grep sddm
We need to understand why sddm exits after starting.

Also try the following: login to tty2 and issue sudo systemctl restart sddm.service then change to tty1 (or tty7).

Sorry about all the photos. The output-to-file syntax with > isn’t working for some reason.

restarting sddm gets me back to tty1 automatically and it’s the same as before.

Hey just wanted to see if anyone can make something of this boot problem, so bumping this topic, I really need to get my hands on this OS.

Can’t believe that this
journalctl -b | grep sddm > myprotocol

isn’t working.
It might be hard to post the contents of the resulting file from the console.
But you could get to the file by booting from usb …

The only guess I have is something like wgetpaste (of which I heard) which will upload the file to some host and return a link to it.

As of now, only you can analyze the output.
The photos are unreadable and also only contain a small portion of the whole output.

pipe the command through less - it’s easier to scroll and read

journalctl -b | grep sddm | less

The output says that there is no more storage space available on this device.

I made sure that all the output is there! obviously the photos are not the most easily readable, but I can manage fine at least on my laptop screen, it enlarges the picture for me when I click it.

can’t you delete some files to make some space?
the pacman cache, for instance?
it lives in:
/var/cache/pacman/pkg

sudo paccache -rk1
or
sudo paccache -rk0

to free it

or
sudo rm -f /var/cache/pacman/pkg/*

to just delete it

or

sudo tune2fs -m 1 /dev/sdxx

to be able to use some space previously only accessible to root

or

sudo journalctl -b | grep sddm > myprotocol

(which should get around the reserved block percentage because it is run as root)

quite a few options …

1 Like

in the two photos there is definitely not all the output there was from that command
it is unreadable anyway - at least for me

will still work and you’ll be able to scroll through and read - no storage required

This is also consistent with the problem I was experiencing before this (full SSD), but KDE partition manager reports a good 15 GB free on this partition (size: 359,38 GB, used: 344,54 GB). I’ll try to free up more space suing your suggestions.

So, apparently 15 available GB was not enough, but the space I gained using

and

was enough: the system booted now! Free space is now 33 GB (indeed I ran out during a system update, so it makes sense a lot would be freed up deleting the pacman cache!).

Still it comes as a surprise that Manjaro wouldn’t boot with 15 GB available.
To fix this problem , I’m thinking of enlarging the partition that Manjaro is residing on.
Would you say this is safe?

after this
now only 1% is reserved to the root user
the default value before that was 5%
the margin for error is now smaller …

these 15GB where these 5%
only accessible to the root user
Now you have 3 GB safety margin left (~300 GB partition)

15 GB (5% - the default) was quite a lot
3 GB (1% now) is still quite a lot
maybe it’s not necessary to enlarge the partition

just make sure that the logs don’t grow too large - and maintain the pacman cache …

resizing a partition works, but is still risky
have backups before attempting it!

1 Like