Bold Italic fonts in browsers

This issue has survived me fixing up Plasma with a revamp of my .config folder and is the same if I create a new user. It isn’t an issue with specific browsers, or with browser settings…

I spent a fair amount of time in Fontmanager removing fonts I don’t want (I have many Asian style fonts - rather too many versions of Noto, Akruti, Akaash etc) so I disabled many and deleted quite a few too.

So my question is - can anyone figure out why all browsers now seem to default to this bold italic font for websites.

Also, aside from a complete reinstall - how can I work out the issue/font problem and get the browsers to render normally?

Two things spring to mind…

  1. Check your browser settings for whether they are set to use the site’s fonts or your own fonts.

  2. If the latter, check what font it is that they use, and change it to a different one.

Now, I don’t know what browsers you are using, although I do recognize Vivaldi as the one in the lower right corner. Sadly, I don’t know enough about it to tell you where to look.

For Firefox and clones thereof, you would go into the Settings menu, and on the first settings page, scroll down until you see “Language and Appearance” — the Fonts section is under that header, and the Advanced button lets you select whether to use your own fonts or those that the website itself prefers.

In Chromium and Google Chrome, enter the Preferences menu and then on the left side of the window, select “Appearance”. Then, in the main window, select Customize Fonts.

If using Firefox, definitely checkout Settings > General or about:preferences. Scroll until you hit the Fonts section and click Advanced. It should look something like this.

Regarding fonts in the Font Manager. I also disabled a number of fonts. Font Manager updates a file ~/.config/fontconfig/conf.d/78-Reject.conf.

I don’t think deleting a font is a long-term solution. Could possibly come back if in an update… There are some threads on font reduction that suggest using NoExtract in pacman.conf. I actually did a combo of Font Manager and pacman.conf, especially for noto. I did the same with the man pages. I really like to search the system with locate, and the number of superfluous results was time consuming.

Well I fixed it for Firefox - but the real issue is that with any browser, now, the default is wildly different - using heavy italic bold fonts - to any other device.

Now I’m seeing other apps with some issues:

How can I reset the fonts? This isn’t covered in the settings…

Annoying issue.
Launching Clipgrab in terminal reveals a message about Segoe font, disabling that fixed clipgrab, and also the browsers…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.