Blurred icons on task bar

My taskbar suddenly shows blurred/stretched icons. This happens often, and the only solution I find is to restart my laptop. I have created a screenshot, see below.

Is there anything I can do to solve this without logging out?
Thanks for your help.

You need to provide some info so the boys can help you. At least your hardware (so a inxi -Fxxxz), which video drivers you are using, journal logs if they show errors and a picture of you compositor settings on Monitor and Display settings should be also handy.

If I were you, I would start by changing the overall theme and icon theme and most importantly, the rendering backend on compositor settings, to see if this makes any impact on the issue. Regards.

Here we go:

System:    Host: roel-xps15 Kernel: 4.14.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.0 
           Desktop: KDE Plasma 5.12.5 tk: Qt 5.10.1 wm: KWin dm: lightdm 1.26.0,sddm 
           Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:   Type: Laptop System: Dell product: XPS 15 9560 v: N/A serial: N/A Chassis: type: 10 serial: N/A 
           Mobo: Dell model: 05FFDN v: A00 serial: N/A UEFI [Legacy]: Dell v: 1.3.4 date: 06/08/2017 
Battery:   ID-1: BAT0 charge: 55.4 Wh condition: 91.7/97.0 Wh (95%) volts: 12.6/11.4 
           model: LGC-LGC8.33 DELL 5XJ2871 type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Skylake rev: 9 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944 
           Speed: 2232 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2232 2: 3135 3: 2561 4: 3348 5: 3067 
           6: 3626 7: 3449 8: 3250 
Graphics:  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8d 
           Display: x11 server: N/A driver: intel resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.0.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Card-1: Intel CM238 HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
           Sound Server: ALSA v: k4.14.44-1-MANJARO 
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci v: kernel 
           bus ID: 02:00.0 chip ID: 168c:003e 
           IF: wlp2s0 state: up mac: <filter> 
           Card-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1:2 chip ID: 0cf3:e300 
           IF-ID-1: docker0 state: up speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: vethcf5c0ad state: up speed: 10000 Mbps duplex: full mac: <filter> 
Drives:    HDD Total Size: 476.94 GiB used: 224.17 GiB (47.0%) 
           ID-1: /dev/nvme0n1 model: PM961 NVMe SAMSUNG 512GB size: 476.94 GiB serial: <filter> rev: CXY73D1Q 
           scheme: MBR 
Partition: ID-1: / size: 451.89 GiB used: 224.17 GiB (49.6%) fs: ext4 dev: /dev/nvme0n1p1 
           ID-2: swap-1 size: 16.82 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 57.0 C mobo: 42.0 C 
           Fan Speeds (RPM): cpu: 2509 
Info:      Processes: 259 Uptime: 1d 19h 31m Memory: 15.29 GiB used: 9.26 GiB (60.6%) Init: systemd v: 238 
           Compilers: gcc: 8.1.0 clang: 6.0.0 Shell: bash v: 4.4.19 running in: konsole inxi: 3.0.08 

I can try some of your suggestions to try finding the root cause, but if there’s a command to restart or refresh the task bar (if possible) that would already help a lot.

Creste a script to kill plasma shell:
#!/bin/bash
kquitapp5 plasmashell
wait 2
kstart5 plasmashell

Then run it.

1 Like

I would start by updating your system. You are using a system release, kernel and KDE stack at least 4 months old. That could be a great start.

1 Like

Yeah you are right, this is obviously necessary thing to do!

Ok, that’s indeed a good start :frowning: Ive been using ubuntu for years, and updates were kind of ‘automatic’, but with Manjaro I have to start them manually so I always forget.

But good news too: the script of @openminded works like charm! Thanks a lot!

Well, in any rolling release distro, keeping up with updates is kinda important. Much more than in fixed/point releases like Ubuntus. Not only because of security issues, but for stability and avoiding other kind of problems also. So try and get used to do it, at least once a week, that’s my advice.

In any case, unless you have disabled it yourself, you should have the “Octopi Notifier” to warn you about them.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.