Bluetooth won't work at startup

Bluetooth has been working just fine for me for the past month or so since I installed manjaro and then it stops working at startup

1 Like

So your problem is that you have to enable it everytime ?

no like it wont turn on, even when I try enabling it

what happens when you click enable button?
does the following command give any output?

rfkill unblock bluetooth

Did you try switching kernel?

I haven’t tried switching the kernel but I have tried rfkill and it still didn’t work. Can’t really switch kernels bc im in the middle of class rn and this shit might be on my test

1 Like

Jumping on this one as I suspect I have the same issue.
When I start my laptop, blue tooth often doesn’t work. After three or four restart it does.

I have tried the below code but nothing changed.

rfkill unblock bluetooth

When I check status, it appears to be on but it can’t find any device and nothing happens.

 systemctl status bluetooth.service                                                                                                                                                                                                                                                                          
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2022-01-14 17:51:25 GMT; 2min 20s ago
       Docs: man:bluetoothd(8)
   Main PID: 728 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9405)
     Memory: 2.0M
        CPU: 19ms
     CGroup: /system.slice/bluetooth.service
             └─728 /usr/lib/bluetooth/bluetoothd

Jan 14 17:51:25 Edmund systemd[1]: Starting Bluetooth service...
Jan 14 17:51:25 Edmund bluetoothd[728]: Bluetooth daemon 5.62
Jan 14 17:51:25 Edmund bluetoothd[728]: Starting SDP server
Jan 14 17:51:25 Edmund systemd[1]: Started Bluetooth service.
Jan 14 17:51:25 Edmund bluetoothd[728]: Bluetooth management interface 1.18 initialized

EDIT

It took two tried this evening (I’m in luck).
I run the same command to see the difference and the only difference is the Main PID is 683.
I don’t know if that is relevant? I am very new and have a lot to learn…

I am jumping on this also, as I have a similar issue. But is this a real issue?

I have been able to set bluetooth and pair a keyboard thanks to command lines. But the command interface on KDE Plasma is useless, it remains as if I had no bluetooth at all.

And yes, I must pair my keyboard again and again, everytime I log in. Are the problems related? I am not sure.

I, too, have the same issue every time I boot up Manjaro. It’s very rare that the bluetooth is enabled right on first boot. Most of the time, it’s disabled so I can’t use my wireless devices.

My remedy is to keep rebooting until the bluetooth is finally enabled. Note that it also happens to my other two laptops running Manjaro. All my machines are running the latest stable Manjaro KDE and Kernel version 5.15.

I hope there’s anyone out there who could recommend a permanent solution on this issue.