Bluetooth Questions - Airpods

Hello Everyone,

I’ve gotten my Airpods to successfully pair with my Bluetooth on my Dell XPS 13 laptop. However, I now have some follow-up questions:

  1. Is there a way when I switch on (enable) bluetooth, the Airpods are automatically paired?
  2. Currently, Manjaro (KDE) recognizes my Airpods as just headphones. I believe the mic is currently disabled. Is there a way to also enable the microphone correctly?

Any help anyone could provide would be greatly appreciated. Thanks everyone!


Apparently you’re the only one using airpods on a Manjaro system… Your question had 48 views, but no one responded:

:sob: :man_shrugging:

I’m not super knowledgeable but since no one else has responded I figure I can provide better input than nothing. Generally, bluetooth devices use 2 different audio profiles for calls and for normal listening. Most likely your device used the A2DP profile when you are listening to music or otherwise just using your device for audio only purposes. This profile has decent quality. When you connect to a call however, this profile does not support send/recieve audio, so bluetooth has to use a different profile. Usually that profile is lower quality, and you may have to manually change this profile. Usually there may be a “Headphone/Headset” option that you can choose. Headphone is A2DP, and Headset is HFP (hands free). You can read more about them on the “Bluetooth profile” wiki or just google it. There are hacky solutions online that let you change these profiles with a single button if the call program does not automatically switch you over.

I can’t send links unfortunately, but search “How to set up automatic connection of bluetooth headset” online and you should find some potential solutions for getting the device to connect automatically. I wouldn’t bet on it working though, bluetooth in general is just a really frustrating technology.


Man, you are non the only one who use airpods with manjaro


just open the airpod case and on the back hold the button until the light turn blinking white.

on the bluetooth icon , click on device and then click search . you should find the device and connect to it.

on the speaker icon click on sound and change from internal speakers to airpod pro.

all should work now :slight_smile:

Nader B