Bluetooth Mouse randomly disconnects

FYI there is a bug right now with AX200/AX201 chipset bluetooth modules. See https://www.reddit.com/r/linuxhardware/comments/m21yhj/fyi_bluetooth_on_intel_ax200_currently_broken/ for more info. Downgrading linux-firmware seems to help, according to the arch forum

1 Like

Thank you, very useful resource!

1 Like

Hello,
for me the problem still is the same.
On Kernel 5.4 my machine won’t boot at all.
The other versions all give me the behaviour as written in the first post.
Have tried a different BT Mouse with the same result.
All the same hardware still works fine under Win10, as this is a dual boot setup.

I can try a different Linux fron a live version in the next days.
But thanks for into it!

Axel

There are variants of this issue floating around in the internet, especially on the Arch forums. It looks like the blast radius is pretty large.

Here, it’s claimed that the root cause is a bug in bluez, which was patched 2 days ago.

Question to Manjaro devs: how can we get this patch in the quickest way? This is impacting a lot of us.

  • if it’s been patched in Arch, it’ll take 1-2 weeks before showing up in stable.
  • Having said the above, the devs don’t commit to timelines as they’ll release when it’s ready (I.E. out of testing)
  • If you want patches faster, subscribe to the testing branch (but that’s not stable so you could switch now and then switch back to stable once the issue gets releesed to stable)

:frowning:

I don’t think even testing has it yet. We need Bluez to officially release a new version, no?

I just got confirmation from ArchLinux folks that the patch in question made it into bluez 5.56-2. The current version in Manjaro is 5.56-1. Hopefully this will be fixed soon in the next update.

edit: 5.56-2 already in Manjaro unstable.

1 Like

By the way, while we are waiting for the real fix, I noticed that downgrading linux-firmware makes the disconnects much less frequent for me.

pamac install downgrade

sudo DOWNGRADE_FROM_ALA=1 downgrade linux-firmware

I went with the last version from 2020, which seems to work fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.