Bluetooth Doesn't Work on Acer Aspire - Intel Dual Band 3160

Hello guys. I was using Ubuntu and bluetooth hadn’t been working on it too. When after install I booted up Manjaro, bluetooth was working. But then, I rebooted the system and it started to saying that:

No bluetooth adapters found.

I can’t understand. Why is it working after install, until reboot? It worked just for one time. (after every install)
By the way, I am using Windows 8.1 too with dual boot. Bluetooth working perfectly in Windows.

I think these are the outputs that you have to look at them:

inxi -Fazy

  Kernel: 5.10.26-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=0402bc75-919b-49f5-95a7-633fc9945308 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Acer product: Aspire R3-471T v: V3.72 serial: <filter> 
  Mobo: Acer model: EA42_HB v: Type2 - A01 Board Version serial: <filter> 
  UEFI-[Legacy]: Insyde v: 1.07 date: 11/12/2014 
Battery:
  ID-1: BAT1 charge: 46.9 Wh (100.0%) condition: 46.9/53.4 Wh (87.9%) 
  volts: 16.9 min: 15.0 model: SANYO AP13B3K type: Li-ion serial: <filter> 
  status: Full 
CPU:
  Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: 
  L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17566 
  Speed: 1098 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 1098 2: 1098 
  3: 1097 4: 1098 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 2-7:8 
  chip-ID: 04f2:b469 class-ID: 0e02 
  Display: x11 server: X-Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 3926x1080 s-dpi: 96 s-size: 1037x285mm (40.8x11.2") 
  s-diag: 1075mm (42.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  Monitor-2: HDMI1 res: 2560x1080 hz: 60 dpi: 97 size: 670x280mm (26.4x11.0") 
  diag: 726mm (28.6") 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.0.1 
  direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c 
  class-ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.26-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.24 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel modules: wl 
  port: 3000 bus-ID: 03:00.0 chip-ID: 8086:08b3 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 2.05 TiB used: 1 TiB (49.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 4B6Q scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: Expansion 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B 
  serial: <filter> rev: 060E scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 type: USB model: USB3.0 high speed 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 2210 
Partition:
  ID-1: / raw-size: 76.63 GiB size: 74.88 GiB (97.71%) used: 24 GiB (32.0%) 
  fs: ext4 dev: /dev/sda4 maj-min: 8:4 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 191 Uptime: 13h 36m wakeups: 1 Memory: 7.7 GiB 
  used: 2.92 GiB (38.0%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: pacman: 1239 lib: 327 flatpak: 0 Shell: Zsh v: 5.8 
  default: Bash v: 5.1.0 running-in: konsole inxi: 3.3.03

sudo dmesg | grep Bluetooth

[    5.299955] Bluetooth: HCI device and connection manager initialized
[    5.299959] Bluetooth: HCI socket layer initialized
[    5.299962] Bluetooth: L2CAP socket layer initialized
[    5.299970] Bluetooth: SCO socket layer initialized
[   74.753955] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   74.753958] Bluetooth: BNEP filters: protocol multicast
[   74.753962] Bluetooth: BNEP socket layer initialized

Also I have tried to install the Intel WiFi drivers from Intel official page. But they didn’t work. (I installed all versions of them like iwlwifi-ucode-***).

I am new at the forum. I don’t know the rules. If I did something wrong, I am sorry.

First off, don’t install packages from other websites unless you absolutely have to. You should try to stick with our repo and AUR first, and ask for help afterwards. If you install a package from outside of the repos, you’re going to have to manually figure out all of the dependencies, and upgrades yourself.

Your BIOS is pretty old.

You should try updating your BIOS first to see if that fixes anything. If it doesn’t, let us know!

https://www.acer.com/ac/en/US/content/support-product/5673;-;Aspire%20R3-471T

Can you verify that you turned on the bluetooth? My Bluetooth is by default turned off upon booting in, until I right click the icon in my system tray and turn it on.

Also try Kernel 5.4 and Kernel 5.11 to see if that fixes anything as well.


Also, can you please update your outputs with ``` before and after the output? It makes it significantly easier to read.

Thanks!

Before at all, I completly install Windows 8.1 and Manjaro as UEFI. And I updated my BIOS to lastest version that it has.

It doesn’t detect any bluetooth adapter. So I can’t turn on.

I tried 5.4 and several kernel more. But the result is same.

inxi -Fazy

  Kernel: 5.4.100-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=b58e805e-19fe-48d5-9f70-d08e0d7882b2 rw quiet apparmor=1 
  security=apparmor resume=UUID=a9a46794-b939-425b-b6d1-757aafbd0265 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Acer product: Aspire R3-471T v: V3.72 serial: <filter> 
  Mobo: Acer model: EA42_HB v: Type2 - A01 Board Version serial: <filter> 
  UEFI: Insyde v: 1.12 date: 05/17/2016 
Battery:
  ID-1: BAT1 charge: 46.9 Wh (100.0%) condition: 46.9/53.4 Wh (87.9%) 
  volts: 16.9 min: 15.0 model: SANYO AP13B3K type: Li-ion serial: <filter> 
  status: Full 
CPU:
  Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: 
  L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17567 
  Speed: 798 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 798 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 2-7:7 
  chip-ID: 04f2:b469 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 3926x1080 s-dpi: 96 s-size: 1037x285mm (40.8x11.2") 
  s-diag: 1075mm (42.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  Monitor-2: HDMI1 res: 2560x1080 hz: 60 dpi: 97 size: 670x280mm (26.4x11.0") 
  diag: 726mm (28.6") 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c 
  class-ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403 
  Sound Server-1: ALSA v: k5.4.100-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel port: 3000 
  bus-ID: 03:00.0 chip-ID: 8086:08b3 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 262.65 GiB used: 7.35 GiB (2.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 4B6Q scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba 
  model: TransMemory-Ex2 size: 29.76 GiB block-size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition:
  ID-1: / raw-size: 68.36 GiB size: 66.74 GiB (97.62%) used: 7.35 GiB (11.0%) 
  fs: ext4 dev: /dev/sda6 maj-min: 8:6 
  ID-2: /boot/efi raw-size: 474.2 MiB size: 473.2 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda8 maj-min: 8:8 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda7 maj-min: 8:7 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 179 Uptime: 6m wakeups: 1 Memory: 7.69 GiB used: 1.88 GiB (24.5%) 
  Init: systemd v: 247 tool: systemctl Compilers: gcc: N/A Packages: 
  pacman: 1181 lib: 323 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.0 
  running-in: konsole inxi: 3.3.03 

This time, I installed Manjaro and booted up. But bluetooth didn’t work again.