Bluetooth: disable energy saving?

Trouble with USB 2.0 Bluetooth 4.0 Adapter, manufacturer LogiLink, model BT0015:

lsusb:
Bus 006 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Bluetooth keyboard und mouse are paired and running. It seems that energy saving is activated. After 5 seconds the hardware gets laggy, mouse movement after 1 second, same timelag with keyboard.

Installed blueman-manager. When I show devices with blueman-manager, everything is fine. Seems that blueman-manager prevents bluetooth hardware from using energy saving. Where can I disable energy saving/suspend? Didn’t find a solution, spend a lot of time. Thanks.

1 Like

Check tlp settings and you can use tlpui for that … to have a graphical interface to set things up.

Thanks a lot :grinning:

tlp was already installed, additionally I’ve installed tlpui.

Found it at “USB”. USB_AUTOSUSPEND was on. I’ve checked USB_BLACKLIST and added “0a12:0001” to the list. After saving and reboot everything is fine!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.