Bluetooth audio stutter when connected with phone + earbuds

I have my phone connected to my computer and my computer connected to my Bluetooth earbuds. If I play audio through my phone, the audio stutters but does not when the audio being played is from my computer. If it helps, my phone is Samsung Galaxy S21 FE and my earbuds is Soundcore Liberty. Is there any way to fix this stutter?

So you seek help for your phone ?

When playing directly from my phone to my earbuds, there’s no stutter. It’s only when I have my phone connected to my computer connected to my earbuds. It seems like an issue with the Bluetooth in my computer when connected with multiple devices.

I think this will be difficult. Using the computer as a sound router. I haven’t heard that before.
Older Bluetooth versions can only be in contact with one device at a time.
But even with newer ones, it seems to me questionable whether this can work smoothly.

Good luck

:man_shrugging:

It seemed to work fine when I used to use Pop!_OS

Then have you tried another kernel already ?

I also have bluetooth audio stutter since very recently. Updated and rebooted this morning, the issue remains. No phones or other bluetooth devices connected.

Using a Sony WH-1000XM3 on the manjaro testing branch, kernel: 5.15.28-1-MANJARO #1 SMP PREEMPT Fri Mar 11 14:12:57 UTC 2022 x86_64 GNU/Linux

So far I’ve only seen it in chromium 99-based browsers when the CPU is under high load (e.g. playing high-res video or conference calling). Can’t reproduce the issue on firefox. For now I suspect a buffering issue in chromium.

I found the cause of my issue, I could eventually reproduce the problem in other software besides chrome as well.

The WiFi switched to 2.4G instead of 5G for some reason and when there’s a lot of WiFi traffic (e.g. such as when watching a high-res YouTube video) the stutter got really bad. The 2.4G WiFi and BT traffic seem to problematically interfere for low latency BT audio, switching WiFi to 5G solved the issue for now. FWIW I have an Intel AX201 Bluetooth chip.

1 Like

Hi guys!
I also encountered the problem.
The problem is that there is an interference between bluetooth and wifi when it is connected which created the choppy sound.

You have to go in the advanced settings of your wifi network

Look for the option beacon interval or beacon interval it depends on the machines but it’s the same, by default the value is on 100. You will just have to increase this value for example I put it to 104 to keep always good performance wifi and also in autonomy for the battery.

After validating, you will have to restart the computer and then test your bluetooth helmet the problem will have disappeared you can enjoy a sound without cut.

If the problem continues, increase the value of the beacon interval little by little.

By never try to put below 100 because your wifi will be much too powerful with a huge transmission interval but the battery will drain very quickly and never above 400 because the wifi will lose its performance although the battery will have a better autonomy.

To summarize what we have just done is that the time separating the transmissions of beacon when they are set by default on 100 it and very close to the transmission that the bluetooth uses where the interference and the sound chopped and increasing this value have moved away from the value of that which the bluetooth uses and finished the problems.

Hoping that this will solve your problem

I also encountered this issue with any bluetooth audio device I used. I did find this blog post specific to my system but maybe it will work for other systems. After I edited

etc/bluetooth/main.conf

and changed:

# (Multi Profile Selection support)
MultiProfile = multiple

Everything started working normally, no audio issues as of now. Hope this helps.

http://laurentchea.com/post/2020-06-09_manjaro_zenbook_duo/
Here’s the blog post link by the way.

Maybe you can switch to pipewire?