Blender is missing compression options when exporting to glTF

Blender is missing compression options when exporting to glTF: "compression" option missing in the export dialog (Blender 3.0 on manjaro) · Issue #1542 · KhronosGroup/glTF-Blender-IO · GitHub

We get blender from Arch, so you would need to ask the Arch maintainers to include it.

But as draco is currently only in the AUR, it probably won’t happen.

Have you tried installing the AUR package and see if that fixes it?

1 Like

It did not help unfortunately. It seems it is not coming with the required

I tried cheating by symlinking things after install just in case:
ln -s /usr/lib/ /usr/bin/
and declaring it as an environment variable:

Blender does get fooled and offers the compression option in the interface, but i get errors in the console when trying to export:

'/usr/bin/' exists, draco mesh compression is available
10:20:02 | INFO: Starting glTF 2.0 export
10:20:02 | INFO: Extracting primitive: Cube
10:20:02 | INFO: Primitives created: 1
Python: Traceback (most recent call last):
  File "/usr/share/blender/3.0/scripts/addons/io_scene_gltf2/", line 637, in execute
    return, export_settings)
  File "/usr/share/blender/3.0/scripts/addons/io_scene_gltf2/blender/exp/", line 46, in save
    json, buffer = __export(export_settings)
  File "/usr/share/blender/3.0/scripts/addons/io_scene_gltf2/blender/exp/", line 63, in __export
    __gather_gltf(exporter, export_settings)
  File "/usr/share/blender/3.0/scripts/addons/io_scene_gltf2/blender/exp/", line 80, in __gather_gltf
    gltf2_io_draco_compression_extension.encode_scene_primitives(scenes, export_settings)
  File "/usr/share/blender/3.0/scripts/addons/io_scene_gltf2/io/exp/", line 32, in encode_scene_primitives
    dll.encoderCreate.restype = c_void_p
  File "/usr/lib/python3.10/ctypes/", line 387, in __getattr__
    func = self.__getitem__(name)
  File "/usr/lib/python3.10/ctypes/", line 392, in __getitem__
    func = self._FuncPtr((name_or_ordinal, self))
AttributeError: /usr/lib/ undefined symbol: encoderCreate

location: <unknown location>:-1

I have reported this to Arch, hopefully in the right place: FS#73415 : [blender] Blender 3.0 does not offer compression when exporting to glTF

‘/usr/bin/2.82/python/lib/python3.8/site-packages/’ does not exist, draco mesh compression not available

According to this issue, the recommended way is to use the official release on Download — :

You can also try out the Flatpak version:

indeed the flatpak version works! :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.