Blender crashes all the time

Hi all,
I use Blender to sculpt a low-poly landscape. It keeps crashing…this is the message that was in the console:

Anything I can do here?
It’s Blender 3.0.
If you need an INXI, just ask.
Thanks a ton

It would be better if you file a bug report here:

You can also try out the Flatpak version:

1 Like

According to this ⚓ T90247 Blender often crashes with xcb-related error messages some systems/distros got affected in the past, but also not long ago. I can’t reproduce it on my end, but someone mentioned there to configure Blender to not open a new window, configured with Edit > Preferences > Interface > Editors > Temporary Editors > Render In : “Keep User Interface” when rendering.
What version of libx11 do you have installed ? Maybe try to reinstall it …

1 Like

I found that thread too, did’nt help.
I checked libx11; I’m at…
I dont even get to rendering, I do a texture pain, when I try to save the testure, bamm…
Not urgent. I make music, and wanted to make a Blender animation for it…
Thanks for the reply…

Dont flatpaks have the same problem? Or do they really come in one container?
I rarely use flatpaks…so I dont know…

There was a recent issue regarding blender which didn’t existed in the flatpak version so nothing’s wrong in giving it a try:

1 Like

If the one from repos fails, better download from here

Extract it and run the binary from that extracted folder.
I was not able to reproduce neither with the 3.1 alpha build …

1 Like

Okay, super weird…same issue in Debian. This is for the Blender gang, I’m afraid… :thinking:
Edit, I’m somewhat paranoid (one of my more endrearing traits :wink: ) about new(er) stuff, so I investigate. Can I place this in the community as an “RFC” ? Thanks, gang. :hugs:
(downloading straight from the Blender site…)
Edit, the downloaed Blender (3.0.1) feels more stable…we’ll see n wait :wink:

Is there an alternative to Blender I could use until it’s “cured”?

Have you tried the flatpak version yet. It should work AFAIK.

1 Like

I’ll have to stop the project for today…I can impossibly complete a low poly landscape with an animation of a rising sun in time.
O well, I should have started sooner so I had time to get alternatives…instead of that, I trusted that Blender would work…
But…I found a bug, so that is good :wink:
Thanks all, lov ya :smile_cat:
:rose: Melissa :rose:

Possible solution, though I’m still testing…
I have put the rendering on “workbench” instead of “evee”…
No crashes so far…I’m excited… :smile_cat:

I have these crashes for months now. Tried a bunch of possible solutions but none of them worked. Same story here. I hope changing to workbench is the solution for you.

1 Like

So far it’s working…keeping my fingers crossed…
Hope you get some solution too…soon :hugs:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.