Blank screen after backlight@.service

Below the output of the inxi -Fxxxz command:

  Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: i3 4.18.2 info: i3bar dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK 
  product: VivoBook_ASUSLaptop X521IA_M533IA v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: X521IA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X521IA.300 date: 04/13/2020 
  ID-1: BAT0 charge: 45.2 Wh condition: 50.9/50.0 Wh (102%) 
  volts: 11.9/11.9 model: ASUSTeK ASUS Battery type: Li-ion 
  serial: N/A status: Discharging cycles: 6 
  Topology: 8-Core 
  model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 
  type: MCP arch: Zen rev: 1 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a 
  ssse3 svm 
  bogomips: 31952 
  Speed: 1397 MHz min/max: 1400/2000 MHz boost: enabled 
  Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 
  6: 1397 7: 1397 8: 1397 
  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 03:00.0 chip ID: 1002:1636 
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB 
  driver: uvcvideo bus ID: 3-3:3 chip ID: 13d3:56a2 
  serial: <filter> 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa 
  resolution: 1920x1080~60Hz s-dpi: 96 
  renderer: AMD RENOIR (DRM 3.36.0 5.6.19-2-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.5 direct render: Yes 
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  chip ID: 1002:1637 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 03:00.6 
  chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.6.19-2-MANJARO 
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network 
  vendor: AzureWave driver: rtl8821ce v: N/A port: f000 
  bus ID: 01:00.0 chip ID: 10ec:c821 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 476.94 GiB used: 24.61 GiB (5.2%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: FXV7000Q scheme: GPT 
ID-1: / size: 459.50 GiB used: 24.61 GiB (5.4%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-1: swap-1 type: partition size: 8.80 GiB 
  used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: amdgpu 
  temp: 38 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 227 Uptime: 1h 01m Memory: 15.13 GiB 
  used: 1.45 GiB (9.6%) Init: systemd v: 245 Compilers: 
  gcc: 10.1.0 Packages: pacman: 978 Shell: Zsh v: 5.8 
  running in: termite inxi: 3.1.05

Thanks in advance.

can you add these kernels

sudo mhwd-kernel -i linux57
sudo mhwd-kernel -i linux58

reboot , press Esc for appears Grub
and choose in detail version kernel 5.8

minima kernel will be 5.7 for your motherboard & video
& firmware

you can remove after 5.6 ( End Of Life no more update )

sudo mhwd-kernel -r linux56

After installed the kernels you suggested, I’ve rebooted the pc and chosen the linux58 kernel.
However the login screen has never shown up. So I’ve digited ctrl + alt + F2, rebooted the pc and then chosen linux56 and all worked as expected.

can you return

sudo cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=39e35c53-46df-4d4d-ae8d-489efbecdbb0 udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

change this and reboot
in file /etc/default/grub
menu will be visible

sudo nano /etc/default/grub
sudo update-grub

stay on kernel 5.7


Ok thanks, that’s worked!
Also the screen suspend issue seems ok. :slight_smile:
Why not linux58 though?

kerl 5.8 is just started
can you close on solve topic ?

Today when I start up the pc, selected linux57 kernel, I come across this message:

[FAILED] Failed to start Load/Save #ness of backlight:acpi_video0.
[FAILED] Failed to start Light Display Manager.

and I cannot login because the login screen never show up.
So I’ve to reboot and choose linux56 instead.

see this topic

As this post says I’ve run

sudo systemctl disable systemd-backlight@.service

then I shut down the pc. This time at the start up there isn’t the error above but blank screen and no login screen (linux57).

try to log with
Ctrl +Alt +F2 to F7

and after

sudo systemctl start systemd-backlight@.service

I didn’t change anything in the meanwhile you were answering, but this time when I start up and select linux57 the login screen shown up. Isn’t that weird? (without any message like the one before)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.